cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Participant
Participant
5,668 Views
Registered: ‎10-17-2016

How to test the lwIP Echo Server application

Hi,

My development board is zybo,now,I want to test lwIP Echo Server application in SDK,then,what can I do to implement this function?

Regards,

Sophia

0 Kudos
6 Replies
Highlighted
Xilinx Employee
Xilinx Employee
5,659 Views
Registered: ‎08-01-2008

Re: How to test the lwIP Echo Server application

check this application
https://www.xilinx.com/support/documentation/application_notes/xapp1026.pdf
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Participant
Participant
5,653 Views
Registered: ‎10-17-2016

Re: How to test the lwIP Echo Server application

Hi,

I referred to xapp1026,howerver,I don't know enough about how to check the communication between board and PC.

Regards,

Sophia 

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
5,649 Views
Registered: ‎08-01-2008

Re: How to test the lwIP Echo Server application

check this link
http://www.fpgadeveloper.com/2016/01/running-a-lwip-echo-server-on-a-multi-port-ethernet-design.html
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Highlighted
Participant
Participant
5,633 Views
Registered: ‎10-17-2016

Re: How to test the lwIP Echo Server application

Hi,

I'm sorry but I can not open the website http://www.fpgadeveloper.com/2016/01/running-a-lwip-echo-server-on-a-multi-port-ethernet-design.html ,is there another way to check this link?

Regards,

Sophia

0 Kudos
Highlighted
Contributor
Contributor
231 Views
Registered: ‎05-07-2018

Re: How to test the lwIP Echo Server application

Hello balkris,

I tried to apply this project on my custom Zynq Ultrascale+ board. I just changed phy_link_speed as 100Mbps from Autodetect (in temac_adapter_options/BSP's Settings) I get the message in terminal:

-----lwIP TCP echo server ------
TCP packets sent to port 6001 will be echoed back
link speed for phy address 0: 100
DHCP Timeout
Configuring default IP of 192.168.1.10
Board IP: 192.168.1.10
Netmask : 255.255.255.0
Gateway : 192.168.1.1
TCP echo server started @ port 7

So application was running successfully, however when I applied the ping step I get the:

connect: Network is unreachable

and that's all. Should I modify some settings for Zynq? Thanks in advance.

0 Kudos
Highlighted
Moderator
Moderator
189 Views
Registered: ‎07-31-2012

Re: How to test the lwIP Echo Server application

Hi @silat14 ,

I have replied to your post in https://forums.xilinx.com/t5/Ethernet/lwIP-Application-Project-Ping-Error-on-Zynq-Board/m-p/1105973/highlight/false#M18939

Regards

Praveen


-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------