cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
278 Views
Registered: ‎06-13-2019

LWIP echo server will not send more than 1500 bytes over TCP

Jump to solution

I changed the ip_frag_max_mtu to 2000.  This was the only variable with a value of 1500 in the BSP.  I checked over wireshark and the lwip echo server will not send any TCP packets larger than 1500.  How will I change this?

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Adventurer
Adventurer
222 Views
Registered: ‎06-13-2019

I'm using Zynq 7000 and as per UG585 jumbo frames are not supported.  1500 byte payloads are the limit.

View solution in original post

3 Replies
Highlighted
Moderator
Moderator
262 Views
Registered: ‎08-25-2009

Hi @jcwill585 ,

Which IP are you using? Have you enabled Jumbo frames?

Please note, if using zynq PS GEM, jumbo frames are not supported, so you won't be able to send over 1500 bytes.

"Don't forget to reply, kudo and accept as solution."
0 Kudos
Highlighted
Adventurer
Adventurer
230 Views
Registered: ‎06-13-2019

I'm using LWIP 211 version 1.0.  Jumbo frames are enabled.  I'm not sure if I'm using GEM.

0 Kudos
Highlighted
Adventurer
Adventurer
223 Views
Registered: ‎06-13-2019

I'm using Zynq 7000 and as per UG585 jumbo frames are not supported.  1500 byte payloads are the limit.

View solution in original post