UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
8,311 Views
Registered: ‎10-24-2007

MGT / Aurora

Hi all,

I am trying to use a Aurora Core and MGT transceiver to get high Speed serial transmission signal out.
I have run into several problems..

One problem is getting the Aurora Core simulated...
I generated a core using the core generator with the following settings. Streaming, Simplex -Both directions.
I tried to simulate the design using the given tb and the do scripts. The clocks are toggling..but there is not data being transferred.. I tried several versions of the aurora 2.4, 2.6, 2.7, 2.7.1.. Still the same issue.. Do_CC is also not asserted. so idle signals are not being sent... Is there something I am missing...

Also I need to send the high speed signal out to to RF unit...
So there is no initialization signals being sent back..  And tx_d_ready signal from the receiver.
The initialization can be probabaly set by the sender side.. but how does the tx_d_ready signal assrted from the GT_Aurora primitve.
FPGA Board - Xupv2p
FPGA - XC2VP30
My setup is ISE 9.1i Sp3.

Thanks,

Cheers
Shakith

0 Kudos
1 Reply
8,298 Views
Registered: ‎10-04-2007

Re: MGT / Aurora

Hi,
I am not sure which simulation tool you are using.
 
MXE and ISIM doesn't support MGT simluation.
You have to ust SE or PE edition with xilinx smart modules
0 Kudos