cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jjeanmichel_lin
Visitor
Visitor
242 Views
Registered: ‎01-24-2020

Multiple Ethernet Interfaces on ZCU111

Jump to solution

Hi,

I am having a peculiar issue with trying to run two independent Ethernet interfaces on a ZCU111.

I have essentially combined the ps_emio_eth_1g (GEM0 over EMIO) ps_mio_eth_1g (GEM3 over MIO) example projects for petalinux 2019.1 in the repo below.

https://github.com/Xilinx-Wiki-Projects/ZCU102-Ethernet/tree/main/2019.1

U-boot detects both interfaces, and the links come up once I login the ZCU111 and do an ifconfig as shown below.

jjeanmichel_lin_0-1617227723020.png

The issue is that I can only TX/RX using only one of the interfaces at a time - it appears to be the last one that comes up too, which is in line with various forum posts I read.

I have also noticed that if I only leave one interface up (either eth0 or eth1), even if it was not the last one up, the one up exclusively can always ping the device it's connected to and I can ping it from the device as well.

The answer from this post https://forums.xilinx.com/t5/Video-and-Audio/Zynq-UltraScale-VCU-Multiple-Ethernet/m-p/1225181 says "you may have to prepare routing setting on linux" can you elaborate on that?

Most of the other issues I have seen that describe what I am seeing prescribe fixing some source files that I don't have considering I am not using LwIP.

Like here: https://forums.xilinx.com/t5/Processor-System-Design-and-AXI/Microblaze-dual-ethernet-problem-with-LWIP/td-p/873021

My best guess is it has something to do with the macb driver or perhaps the routing I am asking about.

I hope to get more guidance and getting the 2 Ethernet interfaces running concurrently.

 

Thanks

0 Kudos
1 Solution

Accepted Solutions
shabbirk
Moderator
Moderator
191 Views
Registered: ‎12-04-2016

Hi @jjeanmichel_lin 

If the IP addresses are in the same subnet, ping fail is expected. Can you refer to this AR once

https://www.xilinx.com/support/answers/72064.html

 

Regards

Shabbir

View solution in original post

1 Reply
shabbirk
Moderator
Moderator
192 Views
Registered: ‎12-04-2016

Hi @jjeanmichel_lin 

If the IP addresses are in the same subnet, ping fail is expected. Can you refer to this AR once

https://www.xilinx.com/support/answers/72064.html

 

Regards

Shabbir

View solution in original post