cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
deepg799
Explorer
Explorer
778 Views
Registered: ‎01-20-2019

TFTP protocol using light weight example application on ZC706

Jump to solution

Hey, I hope all are doing well,

we are trying to develop an application, where we have to transmit files from Host PC (Ubuntu) to the FPGA board (Zynq 7000 SOC) and visa Versa (from board to Host PC)

I am referring to the Xilinx XAPP1026 LightWeight IP raw mode TFTP application example.

https://www.xilinx.com/support/documentation/application_notes/xapp1026.pdf

Procedure:

1) Enable only raw TFTP application in config file.

2)  flash the tftp.elf file to the board with image.mfs file.

Note:- 1) As per document fsbl.elf file needs to be flash in order to enable the MIO                   clocks. but I am not flashing the fsbl.elf seems not required. 

            2) Freertos repository project bsp is only used for socket programming for Zynq 7000 platform, For my application, FreeRTOS is not required because I am using the raw mode TFTP application

After flashing the binaries, I connected the FPGA board to Ubuntu Host PC via ethernet and made sure the ethernet connection is got establish by pinging the board IP address (ping <board IP>). 

Now My environment setup is ready to send the text format file by running the below TFTP application.

/home/user/@ tftp 192.168.1.10

tftp> put hello.txt

tftp> Transfer Time out

After running the above commands, I met with the above error: Transfer Time out

Can anyone help me to solve this issue?

0 Kudos
Reply
1 Solution

Accepted Solutions
deepg799
Explorer
Explorer
679 Views
Registered: ‎01-20-2019

@nanz the problem got solved, Just need to disable the firewall in Ubuntu by running the below commands:

sudo ufw status -> if status is active than run the below command to disable it.
sudo ufw disable

"Don't forget to reply, kudo and accept as a solution."

View solution in original post

3 Replies
nanz
Moderator
Moderator
695 Views
Registered: ‎08-25-2009

Hi @deepg799 ,

Have you tried with any other PCs to test or only Ubuntu is used?

 

"Don't forget to reply, kudo and accept as solution."
0 Kudos
Reply
deepg799
Explorer
Explorer
680 Views
Registered: ‎01-20-2019

@nanz the problem got solved, Just need to disable the firewall in Ubuntu by running the below commands:

sudo ufw status -> if status is active than run the below command to disable it.
sudo ufw disable

"Don't forget to reply, kudo and accept as a solution."

View solution in original post

nanz
Moderator
Moderator
661 Views
Registered: ‎08-25-2009

Hi @deepg799 ,

Thanks for the update, and it's great to hear the issue is resolved. 

Please mark your own thread as "Accepted solution" so other forum users will benefit from it. Thank you!

 

"Don't forget to reply, kudo and accept as solution."
0 Kudos
Reply