cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
arashr
Explorer
Explorer
2,707 Views
Registered: ‎02-06-2018

Ultrascale+ 100G Ethernet over Optical Fiber

Jump to solution

Hi

 

I'm able to communicate and send data from FPGA to computer through 100G ethernet copper cable successfully. Now I want to try optical fibers.

 

Based on the advice I got here in the forum, I should enable optical fiber connection by sending a command by I2c protocol.

 

However, in the documentation of Ultrascale+ 100G ethernet subsustem, there is nothing about any commands over I2c, but, it talks about an option in "General" tab of IP configuration called "Enable TX OTN Interface" (OTN stands for Optical Transport Network).

 

My question is do I need to send I2c commands? or Enabling the option above would be sufficient?

 

Thank you

0 Kudos
1 Solution

Accepted Solutions
jmcclusk
Mentor
Mentor
3,122 Views
Registered: ‎02-24-2014

This is not a problem in the GTY...  it's in the optical QSFP module that you've plugged into the socket..   you need to carefully examine the QSFP module data sheet, and see if there are any registers that need to be programmed to enable the lasers.

Don't forget to close a thread when possible by accepting a post as a solution.

View solution in original post

11 Replies
jmcclusk
Mentor
Mentor
2,682 Views
Registered: ‎02-24-2014

The way that I read the QSFP specification on page 55,  the lasers in the 4 channels have a default value of being enabled.  So it seems that no action is required by I2C commands to begin transmitting data.

 

Depending on the optical transceiver that you select, it might be needed to configure it for RX and TX rate select via I2C.  

Don't forget to close a thread when possible by accepting a post as a solution.
arashr
Explorer
Explorer
2,668 Views
Registered: ‎02-06-2018
@jmcclusk Thankyou.

I have generated the example design for Ultrascale+ 100G IP Core in which :

1- "Enable TX OTN Interface" is enabled.
2- "IEEE 802.3bj RS-FEC" is disabled. Since Optical QSFP module which I'm using has its own FEC.

I generated the bitcode but the example design does not work on real hardware.

I'm using Optical Fiber loopback adapter. How can I debug the issue?
0 Kudos
allanherriman
Mentor
Mentor
2,645 Views
Registered: ‎01-08-2012

You almost certainly don't want to use the OTN interface if you are trying to connect to another Ethernet port.

arashr
Explorer
Explorer
2,621 Views
Registered: ‎02-06-2018
@allanherriman @jmcclusk

so if I do not turn on OTN, the core wouldn't be different from the core I use for copper cable. It works correctly with copper cable loopback adapter, but It does not work with optical fiber loopback.

Does it mean that the laser transceivers are off? How can I debug it?
0 Kudos
jmcclusk
Mentor
Mentor
2,615 Views
Registered: ‎02-24-2014

Better check the datasheet for your optical transceiver..  It should at a minimum list the control and status registers on the i2c interface.   The lasers should be enabled by default.. but maybe not with this module..   Read the data sheet to see.

Don't forget to close a thread when possible by accepting a post as a solution.
allanherriman
Mentor
Mentor
2,607 Views
Registered: ‎01-08-2012

The first thing to check is the Loss Of Signal indication on the link partner.  (Assuming it has one, of course.  Sometimes there's just a "link" LED that will be off for a variety of L1 and L2 causes.)

arashr
Explorer
Explorer
2,597 Views
Registered: ‎02-06-2018

@jmcclusk

 

Ultrascale+ 100G ethernet subsystem uses GTY transmitters. In GTY Transmitter Documentation, there is one line saying:

 

The GTY transceiver supports these use modes:

Optical channel transport unit (OTU): OTU-1, OTU-2, OTU-3, OTU-4

 

and there is no extra information and no other explanation. There are some DRP registers but I'm not sure which registers are related to optical lasers.

 

The QSFP specification that you sent to me was extremely helpful but I'm not sure if those specifications would be the same for VCU118 board that I'm using.

0 Kudos
jmcclusk
Mentor
Mentor
3,123 Views
Registered: ‎02-24-2014

This is not a problem in the GTY...  it's in the optical QSFP module that you've plugged into the socket..   you need to carefully examine the QSFP module data sheet, and see if there are any registers that need to be programmed to enable the lasers.

Don't forget to close a thread when possible by accepting a post as a solution.

View solution in original post

arashr
Explorer
Explorer
2,582 Views
Registered: ‎02-06-2018

@jmcclusk Thank you! I found the information you mentioned in VCU118 documentation. I'll work on it.

0 Kudos
ilia.kalistru
Visitor
Visitor
1,448 Views
Registered: ‎06-26-2017

I had a similar problem after switching from copper cable to optical QSFP+.

The problem was that LPMode pin of QSFP is 1 by default, and 100GBASE-LR4 trasciever I use does not support operation in low power mode. The problem was fixed when I changed LPMode pin value to 0.

Hope it'll help someone.

flymanxia
Newbie
Newbie
537 Views
Registered: ‎07-23-2020

 Optical Transport Network (OTN) was designed to provide support for optical networking,OTU4 Approximate data rate is 112G Gbit/s. 112G QSFP28
use in 4x28G OTN client links over fiber.

The 100G QSFP28 transceiver modules are designed for use in 100 Gigabit Ethernet links over fiber. 

Both types of QSFP28 have I2C management interface.

If you encounter any problems with the optical module, you can email me, my email address is ricky@fibermall.com.

0 Kudos