cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
akarshana
Adventurer
Adventurer
399 Views
Registered: ‎03-06-2015

Virtex 5 Ethernet in SGMII mode

Virtex 5 Part Number: 5vfx200tff1738

Ethernet Module: Marvell 88E1512 in SGMII Mode

This is customized board, in EDK we are interfacing xps_ll_temac v2.03a by using V5 Hard mac

we are not getting any LINk

Phy address is 1 and we are cross verified hardware and EDK

and also we have read PHY registers but we got wrong ID code

please give me suggestions to get the link and ping the Ethernet

 

Thanks & regards

0 Kudos
Reply
4 Replies
nanz
Moderator
Moderator
385 Views
Registered: ‎08-25-2009

Hi @akarshana ,

Are you using LWIP to verify the link?

What is the console print? Do you know where you are stuck at?

"Don't forget to reply, kudo and accept as solution."
0 Kudos
Reply
akarshana
Adventurer
Adventurer
383 Views
Registered: ‎03-06-2015

I am using LWIP only

console print i got phy link is not detected

 

thanks & Regards

0 Kudos
Reply
nanz
Moderator
Moderator
381 Views
Registered: ‎08-25-2009

Hi @akarshana ,

Can you check if PHY has been initialized correctly in LWIP source codes?

You can also add debug points in the codes and see what it's stuck.

"Don't forget to reply, kudo and accept as solution."
0 Kudos
Reply
akarshana
Adventurer
Adventurer
289 Views
Registered: ‎03-06-2015

yes and also i am attaching debug messages while testing the lwip code please let me know what is the problem

0 Kudos
Reply