cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
rathnakar
Visitor
Visitor
475 Views
Registered: ‎09-06-2018

XAPP1305

Jump to solution

Im trying to implement PS-PL based  EMIO ethernet using the tcl file provided in XAPP1305. When the project is sourced through tcl file,  "1G/2.5G Ethernet PCS/PMA or SGMII core" is created in block diagram. This PCS/PMS core has a pin by name "an_adv_config_vec[15:0]". The tcl file tries to set the value of this vector to "100001", which falls out of the range in 16 bit representation. Due to this error project creation is halted. Can someone help to solve this problem?

Thanks in advance.

0 Kudos
1 Solution

Accepted Solutions
rathnakar
Visitor
Visitor
329 Views
Registered: ‎09-06-2018

Hi @ nanz. No, I didn't.

I got the problem solved by putting the value of an_adv_config_vec[15:0] as 0x9801, as per the PCS/PMA core userguide.

Thanks for the reply.

View solution in original post

2 Replies
nanz
Moderator
Moderator
410 Views
Registered: ‎08-25-2009

Hi @rathnakar ,

Did you download the design from here:

https://github.com/Xilinx-Wiki-Projects/ZCU102-Ethernet

 


-------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal take a look at our Versal Design Process Hub and our Versal Blogs and our Versal Ethernet Sticky Note.

-------------------------------------------------------------------------------------------
0 Kudos
rathnakar
Visitor
Visitor
330 Views
Registered: ‎09-06-2018

Hi @ nanz. No, I didn't.

I got the problem solved by putting the value of an_adv_config_vec[15:0] as 0x9801, as per the PCS/PMA core userguide.

Thanks for the reply.

View solution in original post