cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
307 Views
Registered: ‎12-19-2019

Xilinx ZynqMP jumbo frame not working

Jump to solution

Dear support,

 

We've been trying to bring up Jumbo frame support on a Trenz board running Zynq MPSoC (4CG-1E) . But got the following error when running ifconfig eth0 mtu 9000:

root@petalinux:~# ifconfig eth0 mtu 9000
SIOCSIFMTU: Device or resource busy

We can see via dmes that macb driver is configured and running as it should (according to https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18841740/Macb+Driver )

[ 6.815918] pps pps0: new PPS source ptp0
[ 6.819948] macb ff0e0000.ethernet: gem-ptp-timer ptp clock registered.
[ 6.826652] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 9.966711] macb ff0e0000.ethernet eth0: link up (1000/Full) [ 9.972383] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready

in kernel config file, all the following configured as 'Y':

CONFIG_ETHERNET
CONFIG_NET_CADENCE
CONFIG_MACB
CONFIG_NETDEVICES
CONFIG_HAS_DMA

Is there anything else that I'm missing?

Thanks for your attention,

Lichang

 

 

0 Kudos
1 Solution

Accepted Solutions
Visitor
Visitor
234 Views
Registered: ‎12-19-2019

Re: Xilinx ZynqMP jumbo frame not working

Jump to solution

Thanks@nanz .

Here is the gem3 in ./components/plnx_workspace/sources/linux-xlnx/arch/arm64/boot/dts/xilinx/zynqmp.dtsi 

gem3: ethernet@ff0e0000 {
compatible = "cdns,zynqmp-gem", "cdns,gem";
status = "disabled";
interrupt-parent = <&gic>;
interrupts = <0 63 4>, <0 63 4>;
reg = <0x0 0xff0e0000 0x0 0x1000>;
clock-names = "pclk", "hclk", "tx_clk";
#address-cells = <1>;
#size-cells = <0>;
#stream-id-cells = <1>;
iommus = <&smmu 0x877>;
power-domains = <&zynqmp_firmware PD_ETH_3>;
};

And in ./project-spec/meta-user/recipes-bsp/device-tree/files/system-user.dtsi

/* ETH PHY */
&gem3 {
status = "okay";

compatible = "cdns,zynqmp-gem";
ethernet_phy0: ethernet-phy@0 {
compatible = "marvell,88e1510";
device_type = "ethernet-phy";
phy-mode = "rgmii-id"; /* note: no difference with and without  this line */
reg = <1>;
};
};

BTW, I'm using 2019.2 - both petalinux and Vitis.

Thanks,

Lichang

 

View solution in original post

0 Kudos
5 Replies
Highlighted
Moderator
Moderator
278 Views
Registered: ‎08-25-2009

Re: Xilinx ZynqMP jumbo frame not working

Jump to solution

HI @lichangche ,

What does your DTS look like?

To enable jumbo frame, the compatible should be "cdns,zynqmp-gem".

 

"Don't forget to reply, kudo and accept as solution."
0 Kudos
Visitor
Visitor
235 Views
Registered: ‎12-19-2019

Re: Xilinx ZynqMP jumbo frame not working

Jump to solution

Thanks@nanz .

Here is the gem3 in ./components/plnx_workspace/sources/linux-xlnx/arch/arm64/boot/dts/xilinx/zynqmp.dtsi 

gem3: ethernet@ff0e0000 {
compatible = "cdns,zynqmp-gem", "cdns,gem";
status = "disabled";
interrupt-parent = <&gic>;
interrupts = <0 63 4>, <0 63 4>;
reg = <0x0 0xff0e0000 0x0 0x1000>;
clock-names = "pclk", "hclk", "tx_clk";
#address-cells = <1>;
#size-cells = <0>;
#stream-id-cells = <1>;
iommus = <&smmu 0x877>;
power-domains = <&zynqmp_firmware PD_ETH_3>;
};

And in ./project-spec/meta-user/recipes-bsp/device-tree/files/system-user.dtsi

/* ETH PHY */
&gem3 {
status = "okay";

compatible = "cdns,zynqmp-gem";
ethernet_phy0: ethernet-phy@0 {
compatible = "marvell,88e1510";
device_type = "ethernet-phy";
phy-mode = "rgmii-id"; /* note: no difference with and without  this line */
reg = <1>;
};
};

BTW, I'm using 2019.2 - both petalinux and Vitis.

Thanks,

Lichang

 

View solution in original post

0 Kudos
Highlighted
Visitor
Visitor
226 Views
Registered: ‎12-19-2019

Re: Xilinx ZynqMP jumbo frame not working

Jump to solution

FYI - Relevant kernel message during boot up is attached.

Here is some relevant section:

[ 4.348079] zynqmp_pll_disable() clock disable failed for dpll_int, ret = -13
[ 4.426176] Marvell 88E1510 ff0e0000.ethernet-ffffffff:01: attached PHY driver [Marvell 88E1510] (mii_bus:phy_addr=ff0e0000.ethernet-ffffffff:01, irq=POLL)
[ 4.440080] macb ff0e0000.ethernet eth0: Cadence GEM rev 0x50070106 at 0xff0e0000 irq 28 (80:1f:12:37:34:b7)

0 Kudos
Highlighted
Visitor
Visitor
217 Views
Registered: ‎12-19-2019

Re: Xilinx ZynqMP jumbo frame not working

Jump to solution

It is to do with configuration steps. I've reconfigured it and jumbo frame is working.

 

Thanks

Highlighted
Moderator
Moderator
197 Views
Registered: ‎08-25-2009

Re: Xilinx ZynqMP jumbo frame not working

Jump to solution

Hi @lichangche ,

Brilliant to hear the issue is resolved. Can you please mark your relavent thread as "accepted solutions"? So it will benifit other forum users too. Thank you!

 

"Don't forget to reply, kudo and accept as solution."
0 Kudos