UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer _kumar
Observer
279 Views
Registered: ‎12-28-2016

Zynq 7000 Ethernet PS PL 1Gbps

Hi,

I'm having a design with Zynq 7000 fpga, with 1Gbps SGMII Ethernet interface from PS to PL (along with AXI DMA).

When I connect the board to PC, I can see packets are coming and PL TEMac rx counters are incrementing, but no response received at PC.

I'm using petalinux 2019.1 and Vivado 2019.1. Configuring Petalinux project using HDF file. Attached the dts files and hdf.

Any help on bring up of this interface?

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
245 Views
Registered: ‎08-15-2018

Re: Zynq 7000 Ethernet PS PL 1Gbps

Hi @_kumar,

Here are a few things I would check:

1.) Does your link partner support SGMII? From your post it sounds like you aren't getting any packets on the host PC which have been TX'd by the Zynq device.

2.) You mention that you're using PS/PL ethernet - however in your dtsi files I only see AXI Ethernet, and both of your GEMs are disabled:

GEM_Disabled.PNG

 

Finally, have a look at XAPP 1026 which has some ethernet reference designs for Zynq 7000 series parts:

https://www.xilinx.com/support/documentation/application_notes/xapp1026.pdf

 

The designs use an older version of the tools, but you can use it as a reference for your design.

 

 

Thanks,

Clayton

0 Kudos
Observer _kumar
Observer
176 Views
Registered: ‎12-28-2016

Re: Zynq 7000 Ethernet PS PL 1Gbps

Hi Clayton,

1) The current setup able to receive packets till AXI Ethernet block as shown in attached diagram. May I know does PS Linux should enable any specifics related to AXI DMA and AXI interconnect access?

2) The design uses the PL Ethernet.

For this case, may I know anything wrong in my hdf setup or dts?

 

ZynqSoc_Ethernet.png

0 Kudos
Observer _kumar
Observer
159 Views
Registered: ‎12-28-2016

Re: Zynq 7000 Ethernet PS PL 1Gbps

Hi Claytonr

1. Yes, My link partner supports SGMII.

I have tried two cases, of A. sent ping command to PC and B. send pint command from ARM

A. sent ping command to PC: The ping command response was failing and PC not received any reply from ARM

B. sent ping command from ARM: The ping command response was failing and not sure if the command is reaching the PC or not

 

Any special cases to be taken care when working PL 1Gbps Ethernet over DMA to PS?

1. DMA will try to write to DDR where Linux is running

2. I suspect some DMA tx/rx was not proper

Any help towards this?

0 Kudos
Moderator
Moderator
90 Views
Registered: ‎08-25-2009

Re: Zynq 7000 Ethernet PS PL 1Gbps

Hi @_kumar ,

When you build the design, have you disabled AXI DMA driver in Linux? The macb driver have axi dma driver built in so the standard AXI DMA driver should be disabled. 

 

"Don't forget to reply, kudo and accept as solution."
0 Kudos