UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor ccarrot
Visitor
9,683 Views
Registered: ‎03-27-2015

FMC XM105 Debug Card and VC707 connection problem.

Jump to solution

Hi All,

 

I got  a new FMC XM105 Debug Card yesterday, however, I am facing diffulty when I plug it into my VC707 evaluation board.

 

The VC707 board runs well before, I can correctly dump codes into it and run it. But when I just put the XM105 card onto the FMC HPC connector, no matter which one is, the Hardware Manager always gives error, showing:

 ------------------------------------

[Labtools 27-2269] No devices detected on target localhost/xilinx_tcf/Digilent/21020381213A.

Check cable connectivity and that the target board is powered up then use the disconnect_hw_server and connect_hw_server to re-register this hardware target.

-------------------------------------

 

If I take the XM105 card out, everything goes back (the Hardware Manager can connect the VC707 and dump bitstream onto it).

 

Can anybody tell what is the possible problem? Thank you very much!

1 Solution

Accepted Solutions
Scholar pratham
Scholar
18,001 Views
Registered: ‎06-05-2013

Re: FMC XM105 Debug Card and VC707 connection problem.

Jump to solution

@ccarrot This should work

 

http://forums.xilinx.com/t5/Xilinx-Boards-and-Kits/VC707-FMC-incompatible-with-XM105-Debug-Card/td-p/251778

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
4 Replies
Scholar pratham
Scholar
18,002 Views
Registered: ‎06-05-2013

Re: FMC XM105 Debug Card and VC707 connection problem.

Jump to solution

@ccarrot This should work

 

http://forums.xilinx.com/t5/Xilinx-Boards-and-Kits/VC707-FMC-incompatible-with-XM105-Debug-Card/td-p/251778

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
Xilinx Employee
Xilinx Employee
9,660 Views
Registered: ‎08-01-2012

Re: FMC XM105 Debug Card and VC707 connection problem.

Jump to solution

The FMC XM105 Debug Card is designed to provide access to many of the pins on the FMC connector found on Xilinx FMC-supported boards including the SP601, SP605 and ML605. I do not think XM105 base board support is there for VC707 board. Please refer http://www.xilinx.com/products/boards-and-kits/fmc-cards.html  for more information regarding base board support information  

 

Also once try to debug as per section-4 (JTAG Initialization) and Section-5 (JTAG Configuration) in http://www.xilinx.com/support/answers/51233.html and see any change. 

 

________________________________________________

Please mark this post as an "Accept as solution" in case if it helped to resolve your query. So that it will help to other forum users to directly refer to the answer.

Give kudos to this post in case if you think the information is useful and reply oriented.

0 Kudos
Visitor ccarrot
Visitor
9,651 Views
Registered: ‎03-27-2015

Re: FMC XM105 Debug Card and VC707 connection problem.

Jump to solution

Hi Pratham:

 

Thank you for your information. I jumpered TDI and TDO on the xm105 board, and it now works! Thank you!

0 Kudos
Visitor ccarrot
Visitor
9,648 Views
Registered: ‎03-27-2015

Re: FMC XM105 Debug Card and VC707 connection problem.

Jump to solution

Hi umamahe:

 

According to your mentioned link, the XM105 supports:

 

AC701, KC705, VC707, VC709 ZC702, ZC706, ML605, SP601, SP605

 

Even though it is showing only SP601, SP605 and ML605 on the user-manual. The problem happens on the TDI and TDO connection for the FMC.  Just jumper the TDI and TDO pins on connector J5 of the XM105, gives a JTAG-chain path from the PC to the FPGA chip, then the Hardware Manager can find the device and program it. Thank you for your concern, now it works fine for me.

 

Thank you!

0 Kudos