UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor yuriom
Visitor
318 Views
Registered: ‎09-28-2018

MIG wrongly exposes dm_n[0:8]

Jump to solution

I have been trying to access a custom DDR4 module on my VCU1525 with IP Integrator in Vivado 2018.3. For some unknown reason, the Memory Interface Generator (MIG) keeps exposing dm_n[0:8] pins even if I choose "NO DM NO DBI" for the "Data Mask and DBI" option. What should I do with these pins?

Screenshot from 2019-01-18 12-17-11.png
0 Kudos
1 Solution

Accepted Solutions
Visitor yuriom
Visitor
133 Views
Registered: ‎09-28-2018

Re: MIG wrongly exposes dm_n[0:8]

Jump to solution
Actually, I was getting the dm_n[0:7] pins precisely because I chose a non-ECC DDR4 memory module. If you select an ECC-enabled module, you do not get dm_n. This rule was clearly stated in the manual for the MIG IP.
0 Kudos
2 Replies
Explorer
Explorer
274 Views
Registered: ‎03-31-2016

Re: MIG wrongly exposes dm_n[0:8]

Jump to solution

It is probably because you have selected RDIMM.  Those pins are on the connector pinout so you must drive them to the correct value for the DIMM to function.  The selection just applies a static value and the correct mode register settings.

If you don't have a registered DIMM don't select that configuration.  If you have a custom board with build in memory you need to select component instead.

0 Kudos
Visitor yuriom
Visitor
134 Views
Registered: ‎09-28-2018

Re: MIG wrongly exposes dm_n[0:8]

Jump to solution
Actually, I was getting the dm_n[0:7] pins precisely because I chose a non-ECC DDR4 memory module. If you select an ECC-enabled module, you do not get dm_n. This rule was clearly stated in the manual for the MIG IP.
0 Kudos