UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor sgrey
Visitor
8,541 Views
Registered: ‎03-11-2011

ML605 Damaged Power supply

i have an ML605 that is damaged, (already comment it), i dont measure any voltage at the VCCaux(U91), VCC2.5(U43) and VCC1v, (U42). i can also not see any PWM signals to any of those regulators.  I took the regulators of and apply the required voltage leves with an extern power supply, the FPGA is working, and configurable. 

 

I change the regulatos for new ones,  but there are not voltage at the outputs nor PWM signals commign from U24 (ucd9240). I think the U24 is damaged or unconfigured. What could i do?

 

-Check the UCD9240 configuration with the PMBus adapter?

-Replace the UCD9240 and configure it with the PMBus adapter?

- or could i adquire a Factory-programed UCD9240 for the ML605 board?

 

I'd apreciate any help,

0 Kudos
14 Replies
Teacher eteam00
Teacher
8,537 Views
Registered: ‎07-21-2009

Re: ML605 Damaged Power supply

Suggestion:  You would attract more interest in your thread if you posted links to the ML605 schematics and the ucd9240 datasheet.

 

Instead of requiring each reader to individually search for these docs, you should post the links and make it easier for everyone else.

 

Just a suggestion...

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos
Visitor sgrey
Visitor
8,535 Views
Registered: ‎03-11-2011

Re: ML605 Damaged Power supply

Good idea:

 

UCD9240

http://focus.ti.com/lit/ds/symlink/ucd9240.pdf

 

Schematic Pages 35 to 38

 

0 Kudos
Teacher eteam00
Teacher
8,531 Views
Registered: ‎07-21-2009

Re: ML605 Damaged Power supply

I took the regulators of and apply the required voltage leves with an extern power supply, the FPGA is working, and configurable.

  • "Configurable" is not the same as "working".  Are clocks running, and IO pins functioning correctly?
  • Did you leave any regulators on the board?
  • Is the entire board working with the external power supplies?
  • What non-FPGA functions are not working, or not checked?
  • Did you also check the DRAM VTT regulator?

Ed Mcgettigan (mcgett) is probably the foremost authority on these TI power-supply modules, as used on Xilinx boards.

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos
Visitor sgrey
Visitor
8,517 Views
Registered: ‎03-11-2011

Re: ML605 Damaged Power supply

more details:

-clock are workings, IOs as well.

-I let the other 2 regulators on board, 3.3 and 1.5.

- VTT regulator is working aswell

-I didnt find any clear anormalities in the FPGA functionalities

 

How could I contact  Ed Mcgettigan?

 

thanks

SG

0 Kudos
Xilinx Employee
Xilinx Employee
8,487 Views
Registered: ‎01-03-2008

Re: ML605 Damaged Power supply

I had to check on a couple of items as we aren't publishing the programming information for the UCD9240 currently on the ML605 page.

 

There are two things that you need to do:

 

1) Buy a TI USB GPIO cable for PMBUS programming.  The ML605 included a flyer for a discount on the cable

2) Contact Xilinx Support for additional information on the programming steps and the programming file

 

If you have any issues after opening a WebCase with support please let me know and I will assist as this isn't an common problem.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
Visitor sgrey
Visitor
8,477 Views
Registered: ‎03-11-2011

Re: ML605 Damaged Power supply

I have opened a Web case:

 

WebCase : 869646

 

Thanks for your help

SG

0 Kudos
8,212 Views
Registered: ‎06-10-2011

Re: ML605 Damaged Power supply

Dear sir:

I have the same power problem. my webcase number is  

WebCase : 880181

0 Kudos
8,202 Views
Registered: ‎06-10-2011

Re: ML605 Damaged Power supply

Hi Mcgett: I have open a webcase, but nobody answer this question or contact me to provide me the information on the programming steps and the programming file. Could you help me to check it ?

0 Kudos
Xilinx Employee
Xilinx Employee
8,193 Views
Registered: ‎01-03-2008

Re: ML605 Damaged Power supply

When you file a case on the weekend it will take a bit longer for support to get back to you.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
Newbie skishan
Newbie
5,196 Views
Registered: ‎08-30-2011

Re: ML605 Damaged Power supply

hi,

 

we too have a similar status and observations with the ML605 board.

The powergood LED (DS2) is off and the powergood outputs from (U25) UCD9240 power controller is low. The VCC1V5 is at 0.05V and hence the DDR3PWR led (DS29) too is off.

The BIST and all programs loaded on the board fails to run, but the FPGA is configurable through the JTAG (since the U24 power controller feeding the FPGA power is fine, i guess) and the DONE pin goes high.

 

mcgett,

please advise how to isolate the defective component. do you have any diagnostic code to check the status of the power controllers? The only interface possible is the direct PMBUS access through FPGA .

 

thanks

shyam

0 Kudos
Newbie skishan
Newbie
5,195 Views
Registered: ‎08-30-2011

Re: ML605 Damaged Power supply

webcase registered as per 889349

0 Kudos
Xilinx Employee
Xilinx Employee
5,186 Views
Registered: ‎01-03-2008

Re: ML605 Damaged Power supply

If you think that the problem is due to the TI power controller being corrupted then step 1 is to purchase a TI USB programming cable.  The ML605 was shipped with a discount coupon: http://www.ti.com/tool/usb-to-gpio  The webcase that you opened should provide you with the necessary XML files to use with the TI Fusion Digital Power Designer software http://www.ti.com/tool/fusion_digital_power_designer to reprogram the controller to the original factory conditions.

 

If you think that the problem is due to a bad component on the board then you will need to determine the fault location.  Starting with a measurement of every power supply on the board is a good first step. 

 

 

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos
Visitor 19840914
Visitor
5,062 Views
Registered: ‎10-11-2011

Re: ML605 Damaged Power supply

I have the same problem, but with SP605. I'm reprogram ucd9240 (U26). VCC2V5_FPGA 2.5V, VCCAUX 2.5V now working, but VCCIN_FPGA 1.2V not working.. webcase registered as 894076. Can any one send me XML files to use with the TI Fusion Digital Power Designer software for programing ucd9240(U26) on SP605 board.

0 Kudos
Moderator
Moderator
5,057 Views
Registered: ‎08-10-2007

Re: ML605 Damaged Power supply

19840914, The WTS engineer who will handle your Webcase can provide the XML files to you.

Looking at the case notes, it appears this has now happened and you should have received the XML files.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos