UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor efwasser
Visitor
837 Views
Registered: ‎01-04-2018

MicroZed JTAG frequency problem

Hello everyone!
I'm a student working on a project with the MicroZed board, along with my partner. We are using Vivado 2015.4, Xilinix SDK 2015.4, and a Digilent USB-JTAG Programming Cable (we don't have a Platform Cable USB).
In the beginning, we were able to program the device, in Vivado or SDK, using the hardware manager "Auto Connect" option. Starting some time ago, we can no longer do that: When trying to program the device using the Auto Connect mode, Vivado gets stuck, and SDK gives the massage: "Error while launching program: fpga initialization failed".
We have to use the hardware manager "Open New Target" option, and to lower the JTAG Clock Frequency to 3000000Hz or less.
Is this a problem with the MicroZed JTAG connection? Can it be fixed?
Thank you very much!


P.S.
We have tried using different USB or JTAG cable. We also tried uninstalling and reinstalling some drivers, as described here:
https://forums.xilinx.com/t5/Design-Tools-Others/Can-t-open-target-in-hardware-manager/td-p/639586
https://forums.xilinx.com/t5/Configuration/Vivado-2016-1-There-is-no-valid-target-connected-to-the-server/td-p/765229
We are both pretty novice, so if possible please use simple words and not too technical language. Thank you!

Tags (2)
0 Kudos
3 Replies
Scholar drjohnsmith
Scholar
825 Views
Registered: ‎07-09-2009

Re: MicroZed JTAG frequency problem

sounds like board problems,

 

try lowering the JTAG clk freq to say 1 MHz, 

  else its out with scope, and probe lines to see do you have voltage etc on the JTAG connector.

 

One thing , if you have the HS range, is if you have the pin out add-apter on the end of it, SIL to DIL,

    that can be back to front, and stops the JTAG.

 

Have close look at the labels on the HS adapted.

 

0 Kudos
Visitor efwasser
Visitor
773 Views
Registered: ‎01-04-2018

Re: MicroZed JTAG frequency problem

Thank you, we can try the first suggestion.

Unfortunately I didn't fully understand the second one. We are using the Digilent XUP USB-JTAG Programming Cable.

Someone told me the MicroZed JTAG connector often has connection issues. I don't know if it's true, and if it can be fixed.

0 Kudos
Visitor efwasser
Visitor
582 Views
Registered: ‎01-04-2018

Re: MicroZed JTAG frequency problem

Update: When using MicroZed I/O carrier card JTAG connection, I can use the maximal frequency. So the problem must have been in the MicroZed board JTAG socket.