UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor wimdevesse
Visitor
7,773 Views
Registered: ‎12-04-2014

No JTAG devices found if using 2 FMC cards on ZC706

I have a ZC706 board which contains 2 FMC connectors (1 LPC + 1 HPC). I also have 2 Integretek FMC-200 boards which can plug into these FMC slots.

 

Everything works fine when I plug one of the FMC boards into either FMC connector of the ZC706 carrier board: Vivado 2014.4 is able to successfully program the FPGA. However, when I plug in both cards at the same time (one in each slot) Vivado gives the following error when opening the Hardware Manager:

 

ERROR: [Labtools 27-2269] No devices detected on target localhost/xilinx_tcf/Digilent/210251842687.
Check cable connectivity and that the target board is powered up then
use the disconnect_hw_server and connect_hw_server to re-register this hardware target.
ERROR: [Common 17-39] 'open_hw_target' failed due to earlier errors.

 

 

There seems to be a problem with the JTAG chain: the Digilent USB-to-JTAG module is shown in Vivado without any discovered devices. Board power is provided by the adapter and should be good. All board status LED's are ok.

 

I tried changing the JTAG frequency but that didn't work. One weird observation is that with the highest frequency (30 MHz) the correct number of devices is found (1 Zynq FPGA + 2 FPGA's on the FMC cards + 1 ARM CPU) but all the FPGA's are marked as unknown and have incorrect ID's and IR lengths.

 

Any hints for making me able to program the Zynq FPGA? I am not interested in the FPGA's on the FMC-200 boards.

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
7,760 Views
Registered: ‎08-01-2012

Re: No JTAG devices found if using 2 FMC cards on ZC706

Please check JTAG chain sequence when two FMC cards presents (TDO --> TDI -->TDO--> TDI  etc).

I guess the JTAG chain is not properly covered for both FMC cards. Check whether FMC cards are having any jumper /switch option to enable proper JTAG chaining when inserting both daughter cards simultaneously

________________________________________________

Please mark this post as an "Accept as solution" in case if it helped to resolve your query. So that it will help to other forum users to directly refer to the answer.

Give kudos to this post in case if you think the information is useful and reply oriented.

0 Kudos