UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor lamiastella
Visitor
6,924 Views
Registered: ‎11-28-2012

PCI-e link down in Kintex7 kc705 embedded kit--How to reconfigure it?

Hi,

 

I am trying to run sudo  "./k7_trd_lin_quickstart" following this manual TRD

 

but I the rightmost LED is turned off even after I turn off the PC and turn on the PC and turn on the FPGA again. The previous time my rightmost LED wasn't flashing I did the same and it worked and started flashing and I could run the program.

 

What I found in a document was : "When a Hot Reset is received by the AXI Bridge for PCIe, the link goes down and the PCI Configuration Space must be reconfigured." However not sure if this exactly pertains to the source of my error or how to reconfigure it. Please let me know if you might know the answer.


 

What I receive as error is:

Failed to open statistics file /dev/xdma_stat
/sbin/rmmod xrawdata1.ko; sleep 1
ERROR: Module xrawdata1 does not exist in /proc/modules
/sbin/rmmod xrawdata0.ko; sleep 1; rm -f /dev/xdma_stat
ERROR: Module xrawdata0 does not exist in /proc/modules
/sbin/rmmod xdma_k7.ko
***** Driver Unloaded *****
./k7_trd_lin_quickstart: line 39: cd: ..#: No such file or directory

 

 

Thanks,

Mona.

0 Kudos
2 Replies
Scholar kotir
Scholar
6,904 Views
Registered: ‎02-03-2010

Re: PCI-e link down in Kintex7 kc705 embedded kit--How to reconfigure it?

I have moved this post so that the boards and kits as it is more of board drivers related issue.

--------------------------------------------------​--------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful.
--------------------------------------------------​-------------------------------------------
0 Kudos
Xilinx Employee
Xilinx Employee
6,826 Views
Registered: ‎07-31-2012

Re: PCI-e link down in Kintex7 kc705 embedded kit--How to reconfigure it?

Hi,

 

Thanks for particiapatiing in forums and sorry for the late response.

 

Make sure you are using the same design file as given in this User Guide. i.e use the design files for vivado 2013.1 only to run these files.

 

However i would suggest you to run again and try in the Vivado 2013.2 version along with the files as it has the latest content - link.

 

Also check the known issue page - link.

 

See if these help. Let me know the update so that i can further help you.

 

 

Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.
0 Kudos