UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer nlbutts
Observer
117 Views
Registered: ‎02-22-2008

Unable to connect JTAG to ZCU104 with Window 10

I have been working with a ZCU-104 board for some time, but always booting Linux. Today I tried to use the JTAG to program the FPGA and run the example HW test application in the SDK tools. The XSCT server runs:

15:18:08 INFO	: Launching XSCT server: xsct.bat -interactive C:\projects\Maza\zcu104_fpga\zcu104_rv_ss_2\zcu104_rv_ss_2.sdk\temp_xsdb_launch_script.tcl
15:18:08 INFO	: XSCT server has started successfully.
15:18:08 INFO	: Successfully done setting XSCT server connection channel  
15:18:08 INFO	: Successfully done setting SDK workspace  
15:18:08 INFO	: Registering command handlers for SDK TCF services
15:18:08 INFO	: Connected to target on host '127.0.0.1' and port '3121'.
15:19:20 INFO	: Connected to target on host '127.0.0.1' and port '3121'.
15:19:53 INFO	: Connected to target on host '127.0.0.1' and port '3121'.
15:20:11 INFO	: ----------------XSDB Script----------------
connect -url tcp:127.0.0.1:3121
----------------End of Script----------------

15:21:08 INFO	: Connected to target on host '127.0.0.1' and port '3121'.
15:21:26 INFO	: ----------------XSDB Script----------------
connect -url tcp:127.0.0.1:3121
----------------End of Script----------------

15:25:33 INFO	: Connected to target on host '127.0.0.1' and port '3121'.
15:25:51 INFO	: ----------------XSDB Script----------------
connect -url tcp:127.0.0.1:3121
----------------End of Script----------------

15:28:03 INFO	: Connected to target on host '127.0.0.1' and port '3121'.
15:28:21 INFO	: ----------------XSDB Script----------------
connect -url tcp:127.0.0.1:3121
----------------End of Script----------------

But the tools timeout when I try to program the FPGA or run software on the A53 cores. When I plug J164 into my computer I get three additional USB serial ports:

zcu104_serial_ports.PNG

 

Is there a stand alone driver I need to install in Windows 10?

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
83 Views
Registered: ‎03-07-2018

Re: Unable to connect JTAG to ZCU104 with Window 10

Hi @nlbutts

Try running following command in XSCT and let us know results:

connect 

targets

Open Vivado Hardware Manger:

Connect board to PC and Try autoconnect. Provide snapshot

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Observer nlbutts
Observer
74 Views
Registered: ‎02-22-2008

Re: Unable to connect JTAG to ZCU104 with Window 10

This is what I get with my work computer.

xsct% connect
tcfchan#1
xsct% targets
xsct%

 

This is what I get with my home computer:

xsct% connect
tcfchan#1
xsct% targets
  6  PS TAP
     7  PMU
     8  PL
  9  PSU
    10  RPU (Reset)
       11  Cortex-R5 #0 (RPU Reset)
       12  Cortex-R5 #1 (RPU Reset)
    13  APU (L2 Cache Reset)
       14  Cortex-A53 #0 (APU Reset)
       15  Cortex-A53 #1 (APU Reset)
       16  Cortex-A53 #2 (APU Reset)
       17  Cortex-A53 #3 (APU Reset)
xsct% 
 
So it appears to be a driver/install issue on my work computer. Or could it be a firewall issue?
0 Kudos
Xilinx Employee
Xilinx Employee
66 Views
Registered: ‎08-10-2007

Re: Unable to connect JTAG to ZCU104 with Window 10

In Device Manager, check under 'Jungo' that you see 'WinDriver'.

Right click on 'WinDriver' and open WinDriver properties.  In the WinDriver Properties, check the Driver Version.  If the driver version is a newer version than 10.2.1.0, then this will cause issues.  If you see a newer version, then you will need to revert back to 10.2.1.0.

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer nlbutts
Observer
57 Views
Registered: ‎02-22-2008

Re: Unable to connect JTAG to ZCU104 with Window 10

I don't have a WinDriver or Jungo driver installed anywhere. I'm attaching the ports I have. Those ports are all using an FTDI driver.

ports.PNG
0 Kudos
Xilinx Employee
Xilinx Employee
53 Views
Registered: ‎06-05-2013

Re: Unable to connect JTAG to ZCU104 with Window 10

Have you tried to install the drivers from the script which can be found in Vivado installation directory.
\Xilinx\Vivado\2018.2\data\xicom\cable_drivers\nt64\install_drivers_wrapper.bat -- run this.
If you are using platform cable then you can install the drivers from dlc10_win10 which is in the same directory.
You can also confirm the successful driver installation by looking at the log which is the same directory.

Thanks
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Observer nlbutts
Observer
48 Views
Registered: ‎02-22-2008

Re: Unable to connect JTAG to ZCU104 with Window 10

OK, I tried to run that as admin and got the following log file:

 

INFO: InstallPath="D:\Xilinx\Vivado\2018.2\data\xicom\cable_drivers\nt64\"
windrvr6 is not installed (this is expected for Windows 10 and later)
INFO: Installing Windows 10 pcusb driver...
Microsoft PnP Utility

Processing inf : xpcwinusb.inf
Driver package added successfully.
Published name : oem22.inf


Total attempted: 1
Number successfully imported: 1

INFO: INF file D:\Xilinx\Vivado\2018.2\data\xicom\cable_drivers\nt64\dlc10_win10\xpcwinusb.inf was successfully installed for driver.
INFO: Running digilent installer...

<<<<< Digilent Adept Runtime Setup >>>>>
Installer version: 1.4.6 release: 2015/12/08
Digilent Software Path: C:\Program Files (x86)\Digilent

Your system is up-to-date with the components of this installer.
INFO: Running SmartLynq installer...
INFO: SmartLynq installed successfully

I still don't see a Jungo driver. But I get the same results in the SDK. 

xsct% connect
attempting to launch hw_server

****** Xilinx hw_server v2018.2
  **** Build date : Jun 14 2018-20:42:52
    ** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.

INFO: hw_server application started
INFO: Use Ctrl-C to exit hw_server application



****** Xilinx hw_server v2018.2

  **** Build date : Jun 14 2018-20:42:52

    ** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.



INFO: hw_server application started

INFO: Use Ctrl-C to exit hw_server application




INFO: To connect to this hw_server instance use url: TCP:127.0.0.1:3121



tcfchan#1
xsct% targets
xsct% 
0 Kudos