UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor bsejourne
Visitor
7,411 Views
Registered: ‎04-23-2015

Use of SP601 evaluation board (spartan 6 FPGA)

Hello everyone,

 

I 'm using a SP601 evaluation kit but I cannot start working with it.

After following with precision the entire quickstart manual, I ran a communication terminal for testing the board with the BIST, only the LEDs and UART work. No other test respond.
Also, the Base Reference Design Interface (v 2.0.6.0) keep saying : "Not connected to FPGA".
Some of the ethernet LEDs shine.

 

Any idea ?

 

Thank you

Bastien

0 Kudos
2 Replies
Scholar pratham
Scholar
7,405 Views
Registered: ‎06-05-2013

Re: Use of SP601 evaluation board (spartan 6 FPGA)

Hi @bsejourne,

 

When you run BIST test for FLASH test and other, what do you see on tera term? do you see test failed message on the tera term?

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
forum.png
Visitor bsejourne
Visitor
7,393 Views
Registered: ‎04-23-2015

Re: Use of SP601 evaluation board (spartan 6 FPGA)

Hi Pratham, and thank you.

 

Here is what I get :

 

- Timer test : Random characters. Then every time I press "CPU Reset" button I get some more, but still random.

 

- Flash test : "Initialized Flash library successfully" (sometimes the letters are combinated in wrong order), then "Unkerror test failed. Press PROG to continue."

 

- IIC test :

 

"SRECORDS at: 0x871a0000
Bootloader: Processed (0x)00000320 S-records
Executing program starting at address: 00000000
                         IIC EEPROMet:
Writgdattoeoma008 00003040607000C00F
                                    Readingdata frCparig adaa

ing at address: 00000000"

 

- Ethernet loopback test

 

XPS Ethernetlite Loopback Example:  Failed

- Switch test

 

Data read from GPIO Input
is 0xD
Press the 'PROG' buttn to continue.

- External memory Test

 

Multi-Port Memory Controller Memory Test                                        
Testing address range 0x50200000-0x57FFFFFF.                                            
Iteration 1 of 1                
Pass A) ICache:  On, DCache:  On                                
        TEST0: Write all memory to 0x00000000 and check                                                       
                Writing...                          
                Reading...                          
        Test Complete Status = SUCCESS                                      
        TEST1: Write all memory to 0xFFFFFFFF and check                                                       
                Writing...                          
                Reading...                          
        Test Complete Status = SUCCESS                                      

        TEST2: Testing for stuck together bank/row/col bits                                                           
                Clearing memory to zeros...                                           
                Writing and Reading...                                      
        Test Complete Status = SUCCESS                                      

        TEST3: Testing for maximum ba/row/col noise                                                   
                This test performs 16 word writes followed by 16 word reads                                                                           
                Each 64 bytes inverts the ba/row/col address                                                            
                Initializing Memory to 0xA5A5A5A5...                                                    
                Writing and Reading...                                      
                TEST3.3 - ERROR #1: Address = 0x57DB5380, Data Expected was 0xFF                                                                              

0 Kudos