UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor jgbaldw
Visitor
28 Views
Registered: ‎05-24-2018

XGpio_SetDataDirection hangs

I am using Vivado 2018.1.

On a ZC706 evaluation board I have created a project that implements AXI GPIO blocks to pass data between the PS and PL (both directions). I am now trying to duplicate this design on a ZedBoard.

When targeting a ZedBoard the XGpio_SetDataDirection function does not seem to work. All programs using this function hang. That includes the xgpio_example functions provided.

The function seems to hang when writeReg calls Xil_Out32 with argument 0x41200004. A hard power cycle is required once this failure occurs. Running a new application without power cycling results in the following error:

Error while launching program:
Memory write error at 0x100000. APB AP transaction error, DAP status f0000021

Again, everything workc on the ZC706 board, just not on a ZedBoard (I've tried several with the same result).

Restarting SDK, or creating new projects from scratch has no effect.

 

0 Kudos