UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor joelschad
Visitor
206 Views
Registered: ‎05-18-2018

(edit) MZ - Can't boot from JTAG after prior boot from QSPI/Flash

I am new to Vivado/SDK and am working my way through Avnet's MicroZed tutorials ( zedboard.org/support/design/1519/10 ). I was able to successfully build and run projects through part 4. Part 4 involves creating a FSBL and booting to flash via QSPI.

I am now working through tutorials from MicroZed Chronicles, and am trying to talk to the XADC block.

The problem: I want to program the device via JTAG and run the MZ Chronicles application in RAM, but, based on my console output, I am clearly still executing the code in flash from Avnet part 4. I have rebuilt the project and adjusted the MicroZed's boot jumpers, but to no effect. Also, I intermittently see an error message telling me DDR is held in reset and stopping the JTAG programming process, but even when this message does not come up, the flash code still runs.

What am I missing?

0 Kudos
1 Reply
Visitor joelschad
Visitor
148 Views
Registered: ‎05-18-2018

Re: (edit) MZ - Can't boot from JTAG after prior boot from QSPI/Flash

I rebuilt the project from scratch and it worked with no issues. I do not know what the problem was.

That said, I discovered all the SDK example code in C:\Xilinx\SDK\20xx.x\data\embeddedsw\XilinxProcessorIPLib\... which has been extremely helpful. I wish the tutorials had mentioned all this example code sooner.