cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
praveen_p75
Visitor
Visitor
129 Views
Registered: ‎12-17-2019

BPI FLASH APPLICATION BOOTING ISSUE

hi team

i am facing booting issue with BPI flash (s29gl01gs) with artix 7 fpga. when i run my mcs file and my c application standalone it is working .once i program the flash fpga alone working not application. any one please suggest to something is it required any additional configuration for flash?? 

 

0 Kudos
2 Replies
wduffy
Xilinx Employee
Xilinx Employee
109 Views
Registered: ‎01-21-2013

Hi @praveen_p75,

 

Can you provide more details of the failure scenario?
For example, are you successfully able to program the flash but the application is not running?
Or are you having some issues with programming the flash? If so, can you provide more details such as error messages and also log file?

 

Thanks,
Wendy
Xilinx Technical Support
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
praveen_p75
Visitor
Visitor
97 Views
Registered: ‎12-17-2019

hi @wduffy 

i can successfully able to program the flash but the application is not running. when i run the application program  through sdk it is working fine. but when program the flash along with application it is not working. bootloader is also failing.is their any additional configuration for bpi flash ? in some reference documents i found startupe2 is recommended for handling with bpi flash  .can you please give advice about that ?

0 Kudos