UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
601 Views
Registered: ‎05-03-2018

DLC10 USB cable is not detected w/ Spartan XC6SLX9 / ISE 14.

Jump to solution

Dear all,
I have a problem with the Spartan 6 ( XC6SLX9 ), ISE 14.7 and USBII DLC10 cable,
I can not connect Impact to the cable, I tried to reinstall the drivers but without success.

I'm working on an XP virtual machine.
The cable is not detected.

I have seen that on the site are reported problems with the windrvr6.syso driver.

IMPACT -> Output -> Cable AutoConnect, the USB DLC10 cable is not detected, the LED on the interface turns on correctly green.

I also tested on a Win7 laptop on which I installed ISE 14.7.
In my opinion the problem concerns the windrv6, as we can see from the attached image.

Can anyone solve my problem ?

Thanks in advance.

Best regards,
Andrea

Error.png
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
588 Views
Registered: ‎03-07-2018

Re: DLC10 USB cable is not detected w/ Spartan XC6SLX9 / ISE 14.

Jump to solution

Hi @andreac_avnet

First Uninstall driver on Windows

  1. Navigate to xfndry\HEAD\cust_rtf\bin\ [nt|nt64] or common\bin\ [nt|nt64] in an installed area.                          ( C:\Xilinx\14.7\ISE_DS\common\bin\nt64)
  2. Open cmd console.
  3. Run "wdreg -inf %cd%\windrvr6.inf uninstall"
  4. Run "wdreg -inf %cd%\xusbdrvr.inf uninstall"
  5. Run "net stop XilinxPC4Driver"
  6. Delete "%WINDIR%\system32\drivers\windrvr6.sys"
  7. Delete "%WINDIR%\system32\drivers\xusb*.sys"
  8. Delete "%WINDIR%\system32\drivers\xpc4drvr.sys"

Possibly you will see "missing delete driver files" message.

 

Install drivers on Windows

  1. Disconnect the Xilinx USB cable. Alternatively, you can disabled the USB cable in the device manager first then re-enable them in step 5; in this case, you will not even need to reboot.
  2. Navigate to <Xilinx install>\bin\ [nt|nt64] or <Xilinx install>[nt|nt64] in an installed area.                                         ( C:\Xilinx\14.7\ISE_DS\common\bin\nt64)
  3. Run wdreg -inf windrvr6.inf install
  4. Run wdreg -inf xusbdrvr.inf install
  5. Connect the Xilinx USB cable.
Note: You may need to run the Command Prompt in administrator mode
 

Similar issue is discussed in https://forums.xilinx.com/t5/Configuration/ISE-14-7-iMPACT-won-t-work-with-Platform-Cable-USB/td-p/859173

Remember deleting old driver is important step. Do not skip it.

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
1 Reply
Highlighted
Xilinx Employee
Xilinx Employee
589 Views
Registered: ‎03-07-2018

Re: DLC10 USB cable is not detected w/ Spartan XC6SLX9 / ISE 14.

Jump to solution

Hi @andreac_avnet

First Uninstall driver on Windows

  1. Navigate to xfndry\HEAD\cust_rtf\bin\ [nt|nt64] or common\bin\ [nt|nt64] in an installed area.                          ( C:\Xilinx\14.7\ISE_DS\common\bin\nt64)
  2. Open cmd console.
  3. Run "wdreg -inf %cd%\windrvr6.inf uninstall"
  4. Run "wdreg -inf %cd%\xusbdrvr.inf uninstall"
  5. Run "net stop XilinxPC4Driver"
  6. Delete "%WINDIR%\system32\drivers\windrvr6.sys"
  7. Delete "%WINDIR%\system32\drivers\xusb*.sys"
  8. Delete "%WINDIR%\system32\drivers\xpc4drvr.sys"

Possibly you will see "missing delete driver files" message.

 

Install drivers on Windows

  1. Disconnect the Xilinx USB cable. Alternatively, you can disabled the USB cable in the device manager first then re-enable them in step 5; in this case, you will not even need to reboot.
  2. Navigate to <Xilinx install>\bin\ [nt|nt64] or <Xilinx install>[nt|nt64] in an installed area.                                         ( C:\Xilinx\14.7\ISE_DS\common\bin\nt64)
  3. Run wdreg -inf windrvr6.inf install
  4. Run wdreg -inf xusbdrvr.inf install
  5. Connect the Xilinx USB cable.
Note: You may need to run the Command Prompt in administrator mode
 

Similar issue is discussed in https://forums.xilinx.com/t5/Configuration/ISE-14-7-iMPACT-won-t-work-with-Platform-Cable-USB/td-p/859173

Remember deleting old driver is important step. Do not skip it.

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------