UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor csesco
Visitor
5,475 Views
Registered: ‎11-14-2016

DLC9G install.

I have downloaded and installed the UG344_windows.zip design file in accordance with UG344.pdf on two different Win Xp machines

Using the same BDM one PC shows the debugger in device manager as driver version 2.0.0.2. and on the other PC the same debugger shows as driver version 2.0.0.3

 

What version should be used running Xilinx 9.2.04i?

 


Thank you

Tags (2)
0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
5,452 Views
Registered: ‎04-16-2012

Re: DLC9G install.

Hi @csesco

 

Are you encountering any issues with the version differences when connecting the board using DLC9G cable?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Xilinx Employee
Xilinx Employee
5,445 Views
Registered: ‎08-01-2012

Re: DLC9G install.

Please refer https://www.xilinx.com/support/documentation/user_guides/ug344.pdf to know more details about drive installation issues. Also refer https://www.xilinx.com/support/answers/20429.html

FYI: Platform DLC9G USB cables are not tested with usb3.0.

________________________________________________

Please mark this post as an "Accept as solution" in case if it helped to resolve your query. So that it will help to other forum users to directly refer to the answer.

Give kudos to this post in case if you think the information is useful and reply oriented.

0 Kudos
Visitor csesco
Visitor
5,425 Views
Registered: ‎11-14-2016

Re: DLC9G install.

I have been trying to remotely debug an offshore facility. They informed me that the DLC9G debuggers are ‘unreliable’.  A common failure they see when trying to program a Bit file is; Xilinx responds with an ID-CODE mismatch. When I perform a looping check of the IDCode in iMPACT, frequently there are only 3-7 iterations before a failure is encountered.

 

Testing on the same PCB in my facility, passes 100%.

 

A different facility running the same software informed me that when this happens to them, they reinstall BDM drivers and ‘eventually’ it will start working again.

 

Researching deeper into drivers I discovered that 2 different machines with the same versions of Xilinx, show different Rev of DLL. I don’t know if this is some indication of what is happening, but at the least I would expect them to be the same.

 

  1. What should they be?
  2. Why are they different?
  3. Would this cause intermittent issues?
0 Kudos
Newbie repic
Newbie
190 Views
Registered: ‎09-11-2019

Re: DLC9G install.

 
0 Kudos