UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
5,322 Views
Registered: ‎06-08-2017

Flash memory device not recognized

Jump to solution

I am trying to configure the flash memory on my FPGA board so that it loads a program on startup. I am using vivado 2017.2, and I used their gui tool to generate a configuration memory file. My part comes up in the menu (see attched photo), but there is no entry in the alias section.

 

When I use the hardware manager to program the memory I receive this error:

CRITICAL WARNING: [Labtools 27-2251] Unable to read device properties. Please make sure that the proper configuration memory part is selected.

 

I do not receive and error that programming failed (as I've seen in similar threads), at least not in the message window. But programming does seem to have failed.

 

I have M[2:0]=001 during the programming.

 

Any idea what might be going on here?

 

Thank you!

memory_choice.PNG
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Explorer
Explorer
7,460 Views
Registered: ‎06-08-2017

Re: Flash memory device not recognized

Jump to solution

I had the configuration mode switch on my baseboard connected to the wrong IO on the FPGA board. Thanks for your help.

0 Kudos
6 Replies
Moderator
Moderator
5,290 Views
Registered: ‎09-18-2014

Re: Flash memory device not recognized

Jump to solution

So which FPGA are you using? 7- series? Ultrascale? What does the status register read out indicate? Do you have the proper clock and power integrity? Are you sure that the flash that you have on board that you are trying to program? It has to be the exact same flash that you selected while generating the programming file in Vivado. 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Explorer
Explorer
5,254 Views
Registered: ‎06-08-2017

Re: Flash memory device not recognized

Jump to solution
@tenzinc

I am using a Kintex-7 FPGA.

Is the status register a pin on the FPGA, or can I get it's status in Vivado?

I am using an enculstra MKX1 module, I expect clock and power are OK, but I could try to check to be sure. They don't give detailed power schematics, so I may not really be able to probe the power on board.

On the memory part it says fl512sa1ha1. Does this correspond to the part I selected? The user guide for the FPGA module indicated the part I selected should work.
0 Kudos
Contributor
Contributor
5,207 Views
Registered: ‎01-18-2013

Re: Flash memory device not recognized

Jump to solution

Hi,

 

When you are using vivado hardware manager it will show only spansion(Cypress), macronix and micron flash memories. Which flash memory are you using. If the selected part is not available here you can check it in ISE impact, if it is available you can flash though impact otherwise we should request patch files from xilinx FAE or from vendor.

 

Best Regards,

--Ashok

---------------------------------------------------------------------------
- Please mark the Answer as "Accept as solution" if information provided is helpful.

0 Kudos
Explorer
Explorer
5,203 Views
Registered: ‎06-08-2017

Re: Flash memory device not recognized

Jump to solution

@ashok.cheepati I attached a picture. It is a spansion fl512sa1ha1. I selected s25fl512s-spi_x1_x2_x4 in the select memory part search, as this was the only option for this part.

memory_pic_cropped.jpg
0 Kudos
Xilinx Employee
Xilinx Employee
5,192 Views
Registered: ‎08-10-2008

Re: Flash memory device not recognized

Jump to solution
This flash is supported by Vivado and you choose the correct part. Double check the connection between the flash and FPGA, and after power up, see how the K7 STAT reg shows. Make sure all the power rails for it are good.
------------------------------------------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------------------
Highlighted
Explorer
Explorer
7,461 Views
Registered: ‎06-08-2017

Re: Flash memory device not recognized

Jump to solution

I had the configuration mode switch on my baseboard connected to the wrong IO on the FPGA board. Thanks for your help.

0 Kudos