cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
244 Views
Registered: ‎03-03-2014

Multiboot fails on KC705

Jump to solution

Hi,

I used the XAPP1247 to create a multiboot for my design on the KC705.

When I press the SW14 for PROG button, the fallback works fine.

But it doesn't work on board power up !

I corrupted the multiboot bitstream and I get the CRC_ERROR flag activated in the BOOT_STATUS register.

I guess I've missed something but I can't find what.

Any idea why the fallback process only executes on PROG_B button activation and not on power up ??

Thaks.

Stephane.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Moderator
Moderator
233 Views
Registered: ‎06-05-2013

Re: Multiboot fails on KC705

Jump to solution

Please make sure JTAG cable is disconneted when you are trying to boot from flash. Here is the AR https://www.xilinx.com/support/answers/66954.html

-Harshit 

 
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
2 Replies
Highlighted
Moderator
Moderator
234 Views
Registered: ‎06-05-2013

Re: Multiboot fails on KC705

Jump to solution

Please make sure JTAG cable is disconneted when you are trying to boot from flash. Here is the AR https://www.xilinx.com/support/answers/66954.html

-Harshit 

 
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------

View solution in original post

0 Kudos
Highlighted
Adventurer
Adventurer
224 Views
Registered: ‎03-03-2014

Re: Multiboot fails on KC705

Jump to solution

Hello harshit,

Thanks a lot it solved my problem !

Stephane.