cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MaxClerkwell
Visitor
Visitor
242 Views
Registered: ‎07-17-2021

Neither Vivado 2020.2 nor Vivado Lab 2019.1 want to flash my .bin - What did I do wrong?

I generated a bitstream for the Basys 3 Board. Opening the HW-Manager and flashing the .bit-File to the Digilent/210183B159BAA that gets found by the HW-Manager works just fine.

After that, I added the s25fl032p-spi-x1_x2_x4 as suggested here https://reference.digilentinc.com/learn/programmable-logic/tutorials/basys-3-programming-guide/start and tried to add a configuration-file in the next step.

Funny thing: Opening the <proj>.runs/impl_1/ folder in the Program Configuration Memory Device-dialog box doesn't display my <proj>.bin file. Changing the Files of type:-option in the Specify File-modal clearly shows the <proj>.bin file, is shown in the picture provided below.image.png

 After selecting it I get the error message:
[Labtoolstcl 44-518] Invalid configuration file assigned. Valid file type extension .mcs or .bin
image.png

What have I been doing wrong? Does my bitstream need to be generated differently if I want to flash it to the QSPI?

Thanks in advance.

 

-------------------------------------------------------------------------------
Expert in being newbie
0 Kudos
1 Reply
MaxClerkwell
Visitor
Visitor
150 Views
Registered: ‎07-17-2021

Found the error.

I actually wanted to flash a .bin-file to the QSPI, but generated only the .bit-file.

 

While .bit is correct for the FPGA itself, .bin is used for the QSPI.

Right-click onto Generate Bitstream in Vivado and selecting Bitstream Settings, and enabling bit-File fixed it. HTH 

-------------------------------------------------------------------------------
Expert in being newbie
0 Kudos