UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
181 Views
Registered: ‎07-28-2019

Programming terminated. DONE did not go high....

Jump to solution

Hi All,

I have one spartan 6 board from ex-colleague, and I also meet the same problem.(I attach the log in the last paragraph)

I check the previous solution but not help at all.

I tried:

1.change the "Unused IOB Pins" property to "FLOAT"

2.selecting "Use HighZ intstead of Bypass"

3. slow down the cable speed

 

Can someone give me any guidance?

PS:ISE14.7   win7  64bits

---------------

Validating chain...
Boundary-scan chain validated successfully.
'2': Programming device...
LCK_cycle = NoWait.
LCK cycle: NoWait
done.
'2': Reading status register contents...
[0] CRC ERROR : 0
[1] IDCODE ERROR : 0
[2] DCM LOCK STATUS : 1
[3] GTS_CFG_B STATUS : 0
[4] GWE STATUS : 0
[5] GHIGH STATUS : 0
[6] DECRYPTION ERROR : 0
[7] DECRYPTOR ENABLE : 0
[8] HSWAPEN PIN : 1
[9] MODE PIN M[0] : 1
[10] MODE PIN M[1] : 0
[11] RESERVED : 0
[12] INIT_B PIN : 1
[13] DONE PIN : 0
[14] SUSPEND STATUS : 0
[15] FALLBACK STATUS : 0
INFO:iMPACT:2219 - Status register values:
INFO:iMPACT - 0010 0000 1100 1000
INFO:iMPACT:579 - '2': Completed downloading bit file to device.
INFO:iMPACT:188 - '2': Programming completed successfully.
LCK_cycle = NoWait.
LCK cycle: NoWait
INFO:iMPACT - '2': Checking done pin....done.
'2': Programming terminated. DONE did not go high.
PROGRESS_END - End Operation.
Elapsed time = 3 sec.

0 Kudos
1 Solution

Accepted Solutions
Teacher drjohnsmith
Teacher
158 Views
Registered: ‎07-09-2009

Re: Programming terminated. DONE did not go high....

Jump to solution
looks like it all worked, then did not go "don".
Thats great as it menas most of the problems are solved,

do you have a pull up resistor on the done pin ?
out with scope, see what voltages and wave forms your getting.

I dont think it is, , but also double check the obvious that your trying to program the right device with the right file
<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>

View solution in original post

4 Replies
Teacher drjohnsmith
Teacher
159 Views
Registered: ‎07-09-2009

Re: Programming terminated. DONE did not go high....

Jump to solution
looks like it all worked, then did not go "don".
Thats great as it menas most of the problems are solved,

do you have a pull up resistor on the done pin ?
out with scope, see what voltages and wave forms your getting.

I dont think it is, , but also double check the obvious that your trying to program the right device with the right file
<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>

View solution in original post

Xilinx Employee
Xilinx Employee
115 Views
Registered: ‎08-10-2008

回复: Programming terminated. DONE did not go high....

Jump to solution

Hi, 

 

The data did not shift into Spartan-6 completely. Are you sure you are using a correct bit file? Change the Mode pins to 1 1 and try again please.

------------------------------------------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
---------------------------------------------------------------------------------------------------------
0 Kudos
87 Views
Registered: ‎07-28-2019

Re: Programming terminated. DONE did not go high....

Jump to solution

Hi drjohnsmith,

1. I attach the circuit about the DONE pin. I also measure the waveform about DONE pin, and yes, there is pull-up resistor(R73:330ohm, series with LED) in DONE pin.

2. I check the "DONE pin" waveform when programming. DONE pin go down to 0V for 2s and go up to 3.3V, then show "Program Failed".

DONE circuit.jpg
0 Kudos
76 Views
Registered: ‎07-28-2019

回复: Programming terminated. DONE did not go high....

Jump to solution

Hi iguo,

I attach the MODE circuit, and there are pull-up/down resistor on it.
Current configuration is showed as the figure, MODE0=1, MODE1=0.

Do you mean I need to pull MODE1 to high?

MODE circuit.jpg
0 Kudos