UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
10,726 Views
Registered: ‎06-20-2013

SP605: BPI FLASH Read Problem

Jump to solution

Hi,

 

I have a problem reading from the BPI FLASH on the SP605. The problem is that the 'flash_wait' signal is never asserted indicating that the data is valid after a synchronous read, see attached. I can write to the FLASH (verified via readback using IMPACT) so clocking, reset and pinout is correct.

 

Any ideas?

 

Thanks,

 

Simon

0 Kudos
1 Solution

Accepted Solutions
18,007 Views
Registered: ‎06-20-2013

Re: SP605: BPI FLASH Read Problem

Jump to solution

I found the problem....page 19 of the SP605 schematic clearly states 'Synchronous mode not supported'. This is probably because the FLASH_CLK is not connected to the FPGA and therefore not driven.

3 Replies
Xilinx Employee
Xilinx Employee
10,669 Views
Registered: ‎08-01-2012

Re: SP605: BPI FLASH Read Problem

Jump to solution

Verify SW1 settings:
SW1.2 = OFF
SW1.1 = OFF

 

If any board problem exists the following AR http://www.xilinx.com/support/answers/40399.htm helps.

________________________________________________

Please mark this post as an "Accept as solution" in case if it helped to resolve your query. So that it will help to other forum users to directly refer to the answer.

Give kudos to this post in case if you think the information is useful and reply oriented.

0 Kudos
10,661 Views
Registered: ‎06-20-2013

Re: SP605: BPI FLASH Read Problem

Jump to solution

I can verify that SW1.1 & SW1.2 are both OFF.

 

It is worth pointing out that I am not trying to program the FPGA from FLASH at this stage just writing/reading data to/from it.

 

I don't think that there is anything wrong with the FLASH as I can read it's contents via IMPACT. The problem must be the way that I am interfacing with the FLASH, specific to a read as writing is working correctly.

 

Is there a signal that is only used during a read that I am not driving correctly?

0 Kudos
18,008 Views
Registered: ‎06-20-2013

Re: SP605: BPI FLASH Read Problem

Jump to solution

I found the problem....page 19 of the SP605 schematic clearly states 'Synchronous mode not supported'. This is probably because the FLASH_CLK is not connected to the FPGA and therefore not driven.