cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
514 Views
Registered: ‎02-11-2019

SPI FLASH IS NOT IS FAILED IN IMPACT 14.7

Hello..

i have xilinx impact 14.7 and i am using spartan 6e-XC6SLX45T-3FGG484C with spi flash S25FL064P .

when i try to flash this spi i am getting the error message lke:

INFO:iMPACT - Current time: 22-02-2020 14:15:22
PROGRESS_START - Starting Operation.
'1': SPI access core not detected. SPI access core will be downloaded to the device to enable operations.
INFO:iMPACT - Downloading core file C:/Xilinx/14.7/ISE_DS/ISE/spartan6/data/xc6slx45_spi.cor.
'1': Downloading core...
LCK_cycle = NoWait.
LCK cycle: NoWait
done.
'1': Reading status register contents...
INFO:iMPACT:2219 - Status register values:
INFO:iMPACT - 0011 1100 1110 1100
INFO:iMPACT:2492 - '1': Completed downloading core to device.
'1': ID Check passed.
'1': ID Check passed.
'1': Erasing Device.
'1': Using Sector Erase.
ERROR:iMPACT:2525 - '1': Device has exceeded the allocated time.
'1': Programming Flash.
ERROR:iMPACT:2525 - '1': Device has exceeded the allocated time.
INFO:iMPACT - '1': Flash was not programmed successfully.
PROGRESS_END - End Operation.
Elapsed time = 16 sec.

How to over come this error ?

i am generating .mcs file and i am programming this SPI flash.

i tryed on xilinx 12.2 and 13.4 .

In xilinx 12.2 i am getting the error message like cable setup is not proper check your cable setup?

 

0 Kudos
4 Replies
drjohnsmith
Teacher
Teacher
502 Views
Registered: ‎07-09-2009

the error is the flash has exceeded the time allocated to program it.

So standard engineering practice.

divide up the problem,
I'd suggest lets see if the signals are getting to the flash ?
so out with scope, probe lines , see whats happening if anything,

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
498 Views
Registered: ‎02-11-2019

Hello..

When  i try to scope with logic analyzer i am getting the SCLK when i try to flash after that it is not generaating.

and the CS is in HIGH state,

i am not able to understand how to overcome this problem.

Whether i need to do any changes in Hardware are else i need to do any changes in impact

0 Kudos
drjohnsmith
Teacher
Teacher
496 Views
Registered: ‎07-09-2009

a real scope on the pins will tell you do you have the right voltages , which will debug do you have a board fault or not. Isim cant do that as its internal signals only

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos
341 Views
Registered: ‎02-11-2019

Hello..

I can't understad the what's the problem . till now i did't solve this issue . 

What was the issue that spi flash is not working. Is there any other way for flash the spi core .

 

0 Kudos