UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Newbie gvolpi
Newbie
4,312 Views
Registered: ‎10-24-2016

SVF player loads SPI flash but not configure the FPGA

I developed, generally successfully, a SVF player that is able to execute files prepared with impact 14.7 (the project contains Spartan 6). In particular I am able to perform ID code read, FPGA reconfiguration, loading new firmware. But I have issues when I load the flash attached to the FPGA.

 

In particular the operation is correctly executed, with all received TDOs matching with the expected TDOs, but the FPGA doesn't work correctly. If I execute a "verify" operation, in an additional SVF file, that FPGA looks instead working correctly. The execution of the "verify" step is also successful.

 

Is my SVF player missing any final operation? After the final instruction the TAP control is in IDLE, being the default final state.

 

The verify also succeeds using Impact, that makes me really believe that the firmware is correctly loaded.

 

Thanks for any help.

Tags (2)
0 Kudos
1 Reply
Newbie gvolpi
Newbie
4,243 Views
Registered: ‎10-24-2016

Re: SVF player loads SPI flash but not configure the FPGA

I would like to mention that I have a slightly more stable situation if I run an SVF file with the READ OPCODE or all th FPGA.

0 Kudos