UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
931 Views
Registered: ‎05-03-2018

SmartLynq

Jump to solution

Dear Support,
I have a issue with the SmartLynq:

The SmartLynq was initially working and had installed the fw version 2017.3, using Vivado 2018.2 I managed to upgrade it to version 2018.2.
The procedure is activated automatically when, from Vivado, the connection with the SmartLynq is established, because a version difference is detected.

My goal, however, was to get to version 2018.3. Since I did not have an installation of Vivado 2018.3 available,
I looked in the Xilinx documentation and found this AR71624.

In all honesty I have to admit that I did not understand that the TCL commands indicated must be given from the command prompt of Vivado 2018.3, but I was sorry that the update program made a server download of the last available image and therefore it was independent of the version of Vivado used.
In other words, I did not update the fw but rewrite the already existing version.
The problem is that after this operation, which took place without any error, the SmartLynq is no longer distributed: nothing is displayed on the display and the only "sign of life" is the flashing of the Ethernet interface LED.

Reviewing carefully the operations performed I noticed a strangeness:
the update command as reported in the AR includes the parameter -flash which, however, is not documented.

 

 

the SmartLynq in question is no longer operational and I fear that there are no alternatives to its replacement,

In the TCL Console tab the messages shown are these:
start_gui
open_hw
INFO: [IP_Flow 19-234] Refreshing IP repositories
INFO: [IP_Flow 19-1704] No user IP repositories specified
INFO: [IP_Flow 19-2313] Loaded Vivado IP repository '/home/mpatriarca/DESIGN2019/Vivado/Vivado/2018.3/data/ip'.
open_hw: Time (s): cpu = 00:00:12; elapsed = 00:00:11. Memory (MB): peak = 6626.617; gain = 170.191; free physical = 97240; free virtual = 783718

In the Messages tab The messages shown are these:
[Labtools 27-2223] Unable to connect to hw_server with URL "TCP: 10.54.145.142: 3121".
Resolution: 1. Check the host name, port number and network connectivity.
2. Check to ensure the hw_server is running on the target.

Attached the file vivado.log.

I also tried a USB connection from my laptop using XSDK but the device is not recognized by the operating system (in this case Vindows 10 Enterprise). I confirm that if powered and connected to the network the LED of the ethernet interface is flashing, however, the device does not respond to ping.

Now the SmartLynq "upgraded" is not working anymore.

Can anyone help me ?

Best regards,
Andrea

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
786 Views
Registered: ‎03-07-2018

Re: SmartLynq

Jump to solution

Hello @andreac_avnet 

You can file Service request as mentioned at https://www.xilinx.com/support/quality/product-return.html 

Kindly provide reference of this forum thread. 

 

 

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

View solution in original post

8 Replies
Moderator
Moderator
892 Views
Registered: ‎06-05-2013

Re: SmartLynq

Jump to solution
Hi Andrea,
Can you try to use below command and rerun thee firmware update using 2018.2. Once all of this is successful then you can follow the AR71624 while upgrading to Vivado 2018.3

Use 2018.1 or 2018.2
Step1:
update_hw_firmware -format -reset

Follow the AR#71624 for updating to 2018.3
Let us know if it works or not.

Thanks
Harshit
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Explorer
Explorer
869 Views
Registered: ‎05-03-2018

Re: SmartLynq

Jump to solution

Dear @harshit ,

Something is not clear to me in your message:
to be able to run the command you must first specify to Vivado how to reach the SmartLynq,
to ​​do this I believe you must use the open_hw and connect_hw_server commands. Is it right ?

This is the transcription of Vivado's TCL console.*

The IP address specified is the one that the DHCP server assigned to the SmartLynq when it was first switched on,
I can confirm that the association MAC address and IP address is practically "static",
it does not change even if the devices are switched off and on again.

*
start_gui

open_hw
INFO: [IP_Flow 19-234] Refreshing IP repositories
INFO: [IP_Flow 19-1704] No user IP repositories specified
INFO: [IP_Flow 19-2313] Loaded Vivado IP repository '/apps/xilinx/2018.2/Vivado/2018.2/data/ip'.
open_hw: Time (s): cpu = 00:00:20; elapsed = 00:00:10. Memory (MB): peak = 6240.941; gain = 186.406; free physical = 6536; free virtual = 25743
connect_hw_server -url 10.54.145.142
INFO: [Labtools 27-2285] Connecting to hw_server url TCP: 10.54.145.142: 3121
ERROR: [Labtools 27-2223] Unable to connect to hw_server with URL "TCP: 10.54.145.142: 3121".
Resolution: 1. Check the host name, port number and network connectivity.
2. Check to ensure the hw_server is running on the target.
connect_hw_server: Time (s): cpu = 00:00:10; elapsed = 00:02:10. Memory (MB): peak = 6250.363; gain = 0.031; free physical = 6586; free virtual = 25793
ERROR: [Common 17-39] 'connect_hw_server' failed two to earlier errors.

*

Regards,
Andrea

 

0 Kudos
Explorer
Explorer
860 Views
Registered: ‎07-18-2018

Re: SmartLynq

Jump to solution

@andreac_avnet,

I had an issue like this before, connect to it via USB. And then use the URL flag with something like 10.0.0.1

I was able to connect to the HW via the USB that way and do a reset of the firmware.

 

Xilinx Employee
Xilinx Employee
835 Views
Registered: ‎03-07-2018

Re: SmartLynq

Jump to solution

Hello Adrea,

Is it possible for you send snapshot Smartlynq cable with power ON and connected to PC/Laptop?

Also provide snapshot of Vivado Hardware Manager while connecting cable for all steps (Mainly hardware server setting window and select hardware target window). 

 

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
Explorer
Explorer
811 Views
Registered: ‎05-03-2018

Re: SmartLynq

Jump to solution

Hello @bpatil ,

Attached is the photos.

File name Description: 
XSL-10.jpg the "problematic" smartlynq connected via USB to a linux host for which active launch 2018.2
XSL-10 ethernet.jpg the smartlynq "problematic" powered and connected to the ethernet network, with LEDs on (in intelligent reality)
XSL-11.jpg a "working" smartlynq connected via USB to a linux host for which active launch 2018.2

Hardware server settings.PNG The dialog to display the "Hardware Server Settings" settings
Select hardware target.PNG The display screen to display the "Select hardware destination" window

Best regards,
Andrea

XSL-11.jpg
XSL-10 ethernet.jpg
hardware server settings.PNG
XSL-10.jpg
select hardware target.PNG
0 Kudos
Xilinx Employee
Xilinx Employee
802 Views
Registered: ‎03-07-2018

Re: SmartLynq

Jump to solution

Hello @andreac_avnet 

Correct process for updating Smartlynq cable is provided at https://www.xilinx.com/support/answers/71624.html.

From you snapshots, It seems Smartlynq cable XSL-10 is not updated to 2018.3 firmware correctly.

Please try following procedure:
Connect USB cable to XSL-10
Open HW Manager in the earlier version of the tools Vivado 2017.3
Run the following command in the tcl console (even if cable is not connected to hardware server):
update_hw_firmware -reset
 
Let us know results.
Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
Explorer
Explorer
790 Views
Registered: ‎05-03-2018

Re: SmartLynq

Jump to solution

Hello @bpatil ,
I ran the test in question using Vivado 2017.3 and the SmartLynq connected via USB as specified by you but I had a negative result,
attached the result as shown on the TCL console.

Do you have any ideas about why it's still not working ?
Should I ask for an RMA ?

 

Best regards,
Andrea

Capture.PNG
0 Kudos
Xilinx Employee
Xilinx Employee
787 Views
Registered: ‎03-07-2018

Re: SmartLynq

Jump to solution

Hello @andreac_avnet 

You can file Service request as mentioned at https://www.xilinx.com/support/quality/product-return.html 

Kindly provide reference of this forum thread. 

 

 

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

View solution in original post