UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant mao_jacky
Participant
1,662 Views
Registered: ‎03-28-2016

Unable to connect to hw_server with URL “TCP:LOCALHOST3121”

Hi,As shown in the following figure,the USB Cable drive is ok,but Vivado reported a mistake,why? 

捕获.PNG

捕获1.PNG

0 Kudos
5 Replies
Moderator
Moderator
1,631 Views
Registered: ‎02-09-2017

Re: Unable to connect to hw_server with URL “TCP:LOCALHOST3121”

Hi @mao_jacky,

 

This message normally comes on when the hw_server process is not really running, or is running on a different host or port.

Are you starting the hw_server manually?

When trying to connect, under "open target", are you selecting connect to Local Server or Remote Server and adding the custom host name and port?

Also, if you had the HW Manager opened for too long before connecting, it might automatically kill the hw_server process. Could you try to close Vivado and reopen it?

 

Thanks,

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Participant mao_jacky
Participant
1,618 Views
Registered: ‎03-28-2016

Re: Unable to connect to hw_server with URL “TCP:LOCALHOST3121”

I select Remote Server or Local Server and the error still occurs, here are my steps:

1.This is my PC;

捕获4.PNG

2. I select Remote server

3.捕获5.PNG

3. Then as shown the follow figure. Is there something wrong with my operation?

捕获6.PNG

 

0 Kudos
Moderator
Moderator
1,588 Views
Registered: ‎02-09-2017

Re: Unable to connect to hw_server with URL “TCP:LOCALHOST3121”

Hi @mao_jacky,

 

Could you try to open Vivado and on the initial screen, in the TCL console, type the following command:

 

 

hw_server -s TCP::3121 -d

 

 

You should see a message like this:

 

hw_server -s TCP::3121 -d
WARNING: [Common 17-259] Unknown Tcl command 'hw_server -s TCP::3121 -d' sending command to the OS shell for execution. It is recommended to use 'exec' to send the command to the OS shell.

****** Xilinx hw_server v2018.2
  **** Build date : Jun 14 2018-20:42:52
    ** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.

INFO: hw_server application started
INFO: Use Ctrl-C to exit hw_server application



****** Xilinx hw_server v2018.2

  **** Build date : Jun 14 2018-20:42:52

    ** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.



INFO: hw_server application started

INFO: Use Ctrl-C to exit hw_server application



INFO: To connect to this hw_server instance use url: MY_HOST_NAME:3121

 

 

Then, click on "Open HW Manager", and select the options Open Target -> Open New Target -> Connect to Remote Server and enter the URL provided on the message above:

 

hw_server_connect_remote.jpg

 

If that doesn't work, please check your computer Firewall. It must be blocking inbound and outbound TCP connections to port 3121.

You can make a test by temporarily deactivating the firewall application, closing Vivado and opening it up and trying again (the firewall is either on Windows itself, or you might have a third-party firewall software installed, such as McAfee, Symantec, AVG, Kaspersky, etc.).

 

If that works, then you can reactivate your firewall and then go into the configurations and create a rule to allow Vivado to communicate on port 3121.

 

Thanks,

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Participant mao_jacky
Participant
1,578 Views
Registered: ‎03-28-2016

Re: Unable to connect to hw_server with URL “TCP:LOCALHOST3121”

Hi,  @anunesgu

In the TCL console, type the following command: hw_server -s TCP::3121 -d; vivado show the follow figure: 

捕获7.PNG

 

I don't know what's mean for this. But on other computer, the command can operate normal.

0 Kudos
Moderator
Moderator
1,490 Views
Registered: ‎02-09-2017

Re: Unable to connect to hw_server with URL “TCP:LOCALHOST3121”

Hi @mao_jacky,

 

I apologize for taking longer to reply to you. 

 

That warning is normal. it's just Vivado saying that it's sending the command to the OS Shell (which is what should be done, since the hw_server is a process running in the OS).

 

You can continue normally. Just click on "open HW Manager" and try to connect to the hw_server in the port 3121 (by selecting the option connect to remote server).

Andre Guerrero

Product Applications Engineer

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos