UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor eyalo
Visitor
733 Views
Registered: ‎07-16-2018

XVC and vivado problem: 'refresh device' operation is stuck

Hi All,

I am trying to work with xcku115 (includes FT2232H) and XVC.

xvc server code (https://github.com/tmbinc/xvcd) with a small modification of setting 

ftdi_set_bitmode(&ftdi, 0xFF, BITMODE_SYNCBB); - in the original code it uses CBUS which is not supported on this FTDI device.

 

I am able to connect to this device via the hw manager and even program the device.

 

The problem is that every "Refresh Device" operation is simply stuck forever.

Also after every programming , the vivado initiates a "Refresh Device" operation so even though the bit file was programmed, the vivado is stuck.

 

Did anyone encounter this? 

Perhaps I need to set some specific baud rate/latency timer/something else?

 

I know that a lot of people are working with XVC in a stable way - wondering what am I doing wrong.

 

Thanks In advance.

 

 

0 Kudos
3 Replies
Visitor eyalo
Visitor
684 Views
Registered: ‎07-16-2018

Re: XVC and vivado problem: 'refresh device' operation is stuck

Is there anyone from the Xilinx team that can address this post and provide some assistance?

 

Will be greatly appreciated.

 

Thanks,

Ronen L.

0 Kudos
Visitor eyalo
Visitor
644 Views
Registered: ‎07-16-2018

Re: XVC and vivado problem: 'refresh device' operation is stuck

Hi Again,

 

Is there anyone from Xilinx team that is tracking this forum? or is it a myth? :)

Even just a short reply of "checking this and will get back..." will due.

 

Thanks,

Ronen L.

0 Kudos
Highlighted
Observer jxlannie
Observer
430 Views
Registered: ‎03-12-2013

Re: XVC and vivado problem: 'refresh device' operation is stuck

Hi,I met the same problem. Do you have sovled it? Could you share the experience?Thank you!

0 Kudos