UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
1,459 Views
Registered: ‎12-02-2016

iMPACT error

Hello,

 

I am trying to program XC95288XL CPLD.  I have already generated the .jed file from my VHDL code. I've also tried to reinstall Platform cable drives and Green status light is on. 

I am using ISE14.7

Getting the following error:

 

INFO:iMPACT - Current time: 2018-09-06 12:27:54 PM
PROGRESS_START - Starting Operation.
INFO:iMPACT:583 - '1': The idcode read from the device does not match the idcode in the bsdl File.
INFO:iMPACT:1578 - '1':  Device IDCODE :        00001111111111111111111111111110
INFO:iMPACT:1579 - '1': Expected IDCODE:    00001001011000010110000010010011
PROGRESS_END - End Operation.
Elapsed time =      0 sec.

I have tried to replace CPLD and getting same error. I cannot erase/program the cpld.

 

Please advice what should I do. 

 

Best regards

0 Kudos
15 Replies
Xilinx Employee
Xilinx Employee
1,381 Views
Registered: ‎06-06-2018

Re: iMPACT error

Hello Vastal,

 

Please follow the Xilinx AR#13529 for the error you are facing.

 

Thanks and Regards,

Deepak D N

 

 

-----------------------------------------------------------------------------------------------------------

Please don't forget to give Kudos or Mark it as an Accepted Solution

-----------------------------------------------------------------------------------------------------------

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
1,355 Views
Registered: ‎12-02-2016

Re: iMPACT error

Already Tried this steps as well as reinstalling cable drivers same error every time.

0 Kudos
Xilinx Employee
Xilinx Employee
1,346 Views
Registered: ‎03-07-2018

Re: iMPACT error

Hi @vatsal.naik

 

You can try following procedure for Platform cable USB II to work under Windows 10 environment:

1. Connect cable to PC/Laptop.

2. In device manager if cable is detected then uninstall and delete driver of cable. 

3. Now after connecting cable, it should show unidentified device.

4. Remove platform USB cable

5. Navigate to "C:\Xilinx\14.7\ISE_DS\common\bin\nt64" for 64-bit installs or "C:\Xilinx\14.7\ISE_DS\common\bin\\nt" on 32-bit installs.(using Command Prompt in administrator mode)

6. Run wdreg -compat -inf %cd%\windrvr6.inf uninstall

7. Run wdreg -compat -inf %cd%\windrvr6.inf install

8. Connect the Xilinx USB cable.

 

Also take look at https://www.xilinx.com/support/answers/44397.html and https://www.xilinx.com/support/answers/54381.html

 

If does not work please share snapshot of device driver after connecting cable to Laptop/PC. 

Provide OS and Impact version details.

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
1,339 Views
Registered: ‎12-02-2016

Re: iMPACT error

Hi @bpatil

I have tried this solution, but didn't work. I can see the green status light on platform cable II is on so i think it is connected with proper driver. 

 

I am using Windows10 64-bit OS  & iMPACT 14.7(nt64). Also, I have tried replacing cpld it didn't work. 

 

Please have a look at  attached screenshots.

  1. Device Manager
  2. Impact Device Added
  3. Error Message

 

Let me know if you need anything else. 

 

Thanks!

 

devicemanager.jpg
impact.jpg
error.jpg
0 Kudos
Xilinx Employee
Xilinx Employee
1,213 Views
Registered: ‎03-07-2018

Re: iMPACT error

Hi @vatsal.naik

 

1. Try reducing JTAG frequency and try configuration. It will clarify, there is any problems due to signal integrity.

2. Check power rails are at recommended level or not (while configuration)

3. Currently, which programming cable you are using for configuration?

4. Try changing programming cable and try configuration

5. From which vendor you have purchased CPLD?

6. Provide snapshot of CPLD device on board

7. If possible share configuration schematic of your board.

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
Adventurer
Adventurer
1,203 Views
Registered: ‎12-02-2016

Re: iMPACT error

Hi @bpatil, Thank you for the reply,

 

  1. I have already tried that but same error.
  2. Power rails are ok, already tested it. 
  3. Xilinx Platform Cable II.
  4. I also think this error is because programming cable, I have ordered Digilint XUP USB-JTAG programming cable ( Which           Support 9500XL cpld ) from Digikey, and will try reprogramming once I receive it.
  5. Digikey.ca

I think the programming cable is faulty, and I will wait for the new programming cable and try reprogramming again probably the early week. If that doesn't work I will send you design schematics. Thank you!

 

Best Regards 

0 Kudos
Xilinx Employee
Xilinx Employee
1,184 Views
Registered: ‎06-13-2018

Re: iMPACT error

Hello @vatsal.naik,

 

Please go through the forum post:

https://forums.xilinx.com/t5/Virtex-Family-FPGAs/error-iMPACT-583-1-idcode-mismatch-between-bsdl-file-and-read/td-p/18699

Hope you will get some inputs.

 

Regards,

Naveen

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

0 Kudos
Adventurer
Adventurer
1,173 Views
Registered: ‎12-02-2016

Re: iMPACT error

Hi @nmanitri,

Thanks for the information. In the post, the problem was solved by pull-up resistors, and it is required for Coolrunner-II cpld. 

I am using XC9500XL cpld and  According to this document,

https://www.xilinx.com/support/documentation/application_notes/xapp501.pdf

cpld already has internal pull-up for TDI and TMS Jtag pins, Do we still need external pull-up resistors? Thank you!

 

 

Best Regards

 

 

0 Kudos
Xilinx Employee
Xilinx Employee
1,165 Views
Registered: ‎03-07-2018

Re: iMPACT error

Hi @vatsal.naik

 

Check UG445 (v1.2) Page 12 

Xilinx UG445 CPLD I_O User Guide.jpg

I hope this clarifies your query.

 

Regards,

Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

 

Regards,
Bhushan

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------
Xilinx Employee
Xilinx Employee
1,029 Views
Registered: ‎06-13-2018

Re: iMPACT error

Hello @vatsal.naik,

 

Agree with @bpatil if it not work. Please check  XAPP501 on page 9.

 

idcode3.PNG

 

Hope this will help you.

 

Regards,

Naveen

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

 

Adventurer
Adventurer
1,020 Views
Registered: ‎12-02-2016

Re: iMPACT error

Hi @bpatil @nmanitri

 

I will try with external pull up resistor of 4.7KOhms. XAPP501 really confused me, On page 9. It says that for XC9500XL already have internal pull-ups and doesn't require any external pull-ups since pins are dedicated for JTAG use only.

 

Best Regards

0 Kudos
Xilinx Employee
Xilinx Employee
1,014 Views
Registered: ‎06-13-2018

Re: iMPACT error

Hello @vatsal.naik,

 

Did you check TCK frequency?

The JTAG Clock for the XC9500/XL devices, TCK, has a maximum frequency of 10 MHz.

I suggest you please check TCK clock frequency. Depending on what you find you may be able to fix the signal integrity problem with the capacitor or a resistor.

 

Regards,

Naveen

-------------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
-------------------------------------------------------------------------------------------------------------------------------------------------

0 Kudos
Xilinx Employee
Xilinx Employee
978 Views
Registered: ‎06-06-2018

Re: iMPACT error

Hi @vatsal.naik,

 

I hope this clears your confusion regarding external pull up resistor. Since XC9500XL devices have internal pull up there is no need of connecting external pull up. 

CPLD.PNG

 

 

Please check all the power rails are noise free and are within the range. I hope you went through AR#13529. And please go through general JTAG check list from above image. 

 

Regards,

Deepak D N

 

 

---------------------------------------------------------------------------------------------------------------------------------------------------------

Please Reply or Give Kudos or Mark it as an Accepted Solution.

----------------------------------------------------------------------------------------------------------------------------------------------------------

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
962 Views
Registered: ‎12-02-2016

Re: iMPACT error

@Hi @ddn,

 

That is what I said earlier, that I'm using XC9500XL cpld, so there won't be any need for external pull-up resistors for JTAG.

 

Thanks!

0 Kudos
Adventurer
Adventurer
937 Views
Registered: ‎12-02-2016

Re: iMPACT error

Update,

The problem has been solved by replacing programming cable.

I am not sure why but windows always detected the platform cable, and the status light on platform cable was also responding correctly. Just was not able to program with it.

 

Thank you all, Appreciate your help!

0 Kudos