cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
jyurri
Visitor
Visitor
43,048 Views
Registered: ‎04-09-2010

installing platform cable USB II (ubuntu)

Jump to solution

Hi!

 

I am trying to install the platform cable usb II in my ubuntu 9.10 but I cannot (Xilinx version 11.5). When I plug in the cable, dmesg comand reports the next:

 

[  817.752040] usb 6-1: new full speed USB device using uhci_hcd and address 18
[  817.872042] usb 6-1: device descriptor read/64, error -71
[  818.096022] usb 6-1: device descriptor read/64, error -71
[  818.312038] usb 6-1: new full speed USB device using uhci_hcd and address 19
[  818.432039] usb 6-1: device descriptor read/64, error -71
[  818.656038] usb 6-1: device descriptor read/64, error -71
[  818.872039] usb 6-1: new full speed USB device using uhci_hcd and address 20
[  819.280022] usb 6-1: device not accepting address 20, error -71
[  819.392043] usb 6-1: new full speed USB device using uhci_hcd and address 21
[  819.804047] usb 6-1: device not accepting address 21, error -71
[  819.804061] hub 6-0:1.0: unable to enumerate USB device on port 1

 

And after useing this guide (http://www.george-smart.co.uk/wiki/Xilinx_JTAG_Linux) it still doesn't work.

The xusbdfwu.rules file is: 

 

 ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0008", MODE="666"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0007", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusbdfwu.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0009", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_xup.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="000d", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_emb.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="000f", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_xlp.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0013", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_xp2.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0015", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_xse.hex -D $tempnode"

 

and  lsusb reports:

 

Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 002: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

 

 I followed other similar guides and forums without result. Can somebody help me? I don't know why the computer don't recognize the cable...

 

When I run impact, I have this warnings:

 

 Connecting to cable (Parallel Port - parport3).
 Linux release = 2.6.31-14-generic.
WARNING:iMPACT -  Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.
 Linux release = 2.6.31-14-generic.
WARNING:iMPACT -  Module parport_pc is not loaded. Please reinstall the cable drivers. See Answer Record 22648.
Cable connection failed.

 

And if i try to install the cable drivers, I have a lot of errors:

 

...

linux_wrappers.c:131: error: (Each undeclared identifier is reported only once
linux_wrappers.c:131: error: for each function it appears in.)
linux_wrappers.c: In function ‘is_high_memory_phys’:
linux_wrappers.c:136: warning: implicit declaration of function ‘virt_to_phys’
linux_wrappers.c:136: error: ‘high_memory’ undeclared (first use in this function)
linux_wrappers.c: In function ‘LINUX_down_interruptible’:
linux_wrappers.c:141: warning: implicit declaration of function ‘down_interruptible’
linux_wrappers.c: In function ‘LINUX_up’:
linux_wrappers.c:146: warning: implicit declaration of function ‘up’
linux_wrappers.c: In function ‘LINUX_create_mutex’:
linux_wrappers.c:151: warning: implicit declaration of function ‘kmalloc’
linux_wrappers.c:152: error: invalid application of ‘sizeof’ to incomplete type ‘struct semaphore’

.... (a lot of lines with similar erros)

Instead of useing the windrvr6, I tried to use the libusb-driver.so, and the cable doesn't work, the errors using impact are:
 GUI --- Auto connect to cable...
// *** BATCH CMD : setCable -port auto
AutoDetecting cable. Please wait.
PROGRESS_START - Starting Operation.
 OS platform = i686.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
File version of /opt/Xilinx/11.1/ISE/bin/lin/xusbdfwu.hex = 1030.
File version of /etc/hotplug/usb/xusbdfwu.fw/xusbdfwu.hex = 1030.
 Using libusb.
 Kernel release = 2.6.31-14-generic.
Cable connection failed.
 OS platform = i686.
Connecting to cable (Parallel Port - parport0).
 libusb-driver.so version: 2009-05-31 18:26:14.
Cable connection failed.
 OS platform = i686.
Connecting to cable (Parallel Port - parport1).
 libusb-driver.so version: 2009-05-31 18:26:14.
Cable connection failed.
 OS platform = i686.
Connecting to cable (Parallel Port - parport2).
 libusb-driver.so version: 2009-05-31 18:26:14.
Cable connection failed.
 OS platform = i686.
Connecting to cable (Parallel Port - parport3).
 libusb-driver.so version: 2009-05-31 18:26:14.
Cable connection failed.
PROGRESS_END - End Operation.
Elapsed time =      3 sec.
Cable autodetection failed.
WARNING:iMPACT:923 - Can not find cable, check cable setup !
Message Edited by jyurri on 04-09-2010 04:32 AM
1 Solution

Accepted Solutions
panorro
Observer
Observer
59,856 Views
Registered: ‎04-08-2010

Hi, few months ago I installed a platform cable USB (DLC9) on my Ubuntu 9.10 and I wrote a small tutorial for myself:

 

(I think I could install it following instructions on http://rmdir.de/~michael/xilinx/)

 

I did:

 

- Install linux packet "fxload"

 

- Install usb-driver-HEAD: http://git.zerfleddert.de/cgi-bin/gitweb.cgi/usb-driver?a=snapshot;h=HEAD;sf=tgz

 

- modify file "/tmp/udev/rules.d/xusbdfwu.rules", changing "$TEMPNODE" by "$tempnode"

 

- define LD_PRELOAD=/path/to/libusb-driver.so. In my case in /home/jlespi/.bashrc I added: export LD_PRELOAD=/opt/usb-driver/libusb-driver.so.

- Restart udev: "sudo restart udev"

 

- Connect usb cable.

 

I know it is not platform cable USB II, but I hope this post can help.

 

regards.

 

 

View solution in original post

7 Replies
panorro
Observer
Observer
59,857 Views
Registered: ‎04-08-2010

Hi, few months ago I installed a platform cable USB (DLC9) on my Ubuntu 9.10 and I wrote a small tutorial for myself:

 

(I think I could install it following instructions on http://rmdir.de/~michael/xilinx/)

 

I did:

 

- Install linux packet "fxload"

 

- Install usb-driver-HEAD: http://git.zerfleddert.de/cgi-bin/gitweb.cgi/usb-driver?a=snapshot;h=HEAD;sf=tgz

 

- modify file "/tmp/udev/rules.d/xusbdfwu.rules", changing "$TEMPNODE" by "$tempnode"

 

- define LD_PRELOAD=/path/to/libusb-driver.so. In my case in /home/jlespi/.bashrc I added: export LD_PRELOAD=/opt/usb-driver/libusb-driver.so.

- Restart udev: "sudo restart udev"

 

- Connect usb cable.

 

I know it is not platform cable USB II, but I hope this post can help.

 

regards.

 

 

View solution in original post

Anonymous
Not applicable
42,770 Views
0 Kudos
jyurri
Visitor
Visitor
42,748 Views
Registered: ‎04-09-2010

Thank you guys!!

 

the problem is alredy solved!

 

regards

0 Kudos
cousteau
Adventurer
Adventurer
41,716 Views
Registered: ‎05-11-2010

jyurri: What solution did work?

I've tried following http://www.train-z.de/ise/howto_install_ISE_on_SuS E.pdf and some other similar tutorials but XPS keeps trying to use windrvr6 instead of libusb-dev.

The error message is:

 

WARNING:iMPACT -  Module windrvr6 is not loaded. Please reinstall the cable drivers. See Answer Record 22648.

 

Software: Ubuntu 10.04 32b, Xilinx 12.1, packages libusb-dev and fxload installed.

Tried modifying my xilinx wrapper script to add   export XIL_IMPACT_USE_LIBUSB=1   and also restarted udev with   sudo service udev restart   but none of them worked.

0 Kudos
jyurri
Visitor
Visitor
41,705 Views
Registered: ‎04-09-2010

Hi cousteau!!

When the libusb-dev is not installed the reported error is always windrvr6. Try to follow this http://www.rmdir.de/~michael/xilinx/ (this web is always updated, with instructions for new ISE versions).

 

Anyway, here is my "/etc/udev/rules.d/xusbdfwu.rules" file,  did you copy the *.hex files to /usr/share/. ??

 

#http://dtupelektro.blogspot.com/2009/10/karmic-koala-spartan-3e-starter-kit.html
#0.- Requisitos: Tener instaldo el ISE Webpack y los paquetes fxload, libusb-dev y el build-essential.
#       sudo apt-get install fxload libusb-dev build-essential
#1.- Suponiendo que ya tenemos instalado el ISE Webpack 11.1 (ó el 10.x), nos movemos al la ruta donde quedó instalado.
#       cd /ruta_instalación_Xilinx/11.1/ISE/bin/lin/ o cd /ruta_instalación_Xilinx/11.1/ISE/bin/lin64/
#Ahí encontraremos los siguientes archivos
#$ ls *.hex
#       xusbdfwu.hex xusb_emb.hex xusb_xlp.hex xusb_xp2.hex xusb_xpr.hex xusb_xse.hex xusb_xup.hex
#Los cuales copiaremos a /usr/share
#sudo cp xusb*.hex /usr/share/

# version 0003
ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0008", MODE="666"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0007", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusbdfwu.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0009", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_xup.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="000d", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_emb.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="000f", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_xlp.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0013", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_xp2.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", ATTRS{idVendor}=="03fd", ATTRS{idProduct}=="0015", RUN+="/sbin/fxload -v -t fx2 -I /usr/share/xusb_xse.hex -D $tempnode"

 

 

This other link can be useful: http://www.george-smart.co.uk/wiki/Xilinx_JTAG_Linux

 

Good luck

 

 




0 Kudos
cousteau
Adventurer
Adventurer
41,689 Views
Registered: ‎05-11-2010

Thanks! This .rules file did the trick:

 

# version 0003
SYSFS{idVendor}=="03fd", SYSFS{idProduct}=="0008", MODE="666"
SUBSYSTEMS=="usb", ACTION=="add", SYSFS{idVendor}=="03fd", SYSFS{idProduct}=="0007", RUN+="/sbin/fxload -v -t fx2 -I /opt/Xilinx/12.1/ISE_DS/ISE/bin/lin/xusbdfwu.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", SYSFS{idVendor}=="03fd", SYSFS{idProduct}=="0009", RUN+="/sbin/fxload -v -t fx2 -I /opt/Xilinx/12.1/ISE_DS/ISE/bin/lin/xusb_xup.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", SYSFS{idVendor}=="03fd", SYSFS{idProduct}=="000d", RUN+="/sbin/fxload -v -t fx2 -I /opt/Xilinx/12.1/ISE_DS/ISE/bin/lin/xusb_emb.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", SYSFS{idVendor}=="03fd", SYSFS{idProduct}=="000f", RUN+="/sbin/fxload -v -t fx2 -I /opt/Xilinx/12.1/ISE_DS/ISE/bin/lin/xusb_xlp.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", SYSFS{idVendor}=="03fd", SYSFS{idProduct}=="0013", RUN+="/sbin/fxload -v -t fx2 -I /opt/Xilinx/12.1/ISE_DS/ISE/bin/lin/xusb_xp2.hex -D $tempnode"
SUBSYSTEMS=="usb", ACTION=="add", SYSFS{idVendor}=="03fd", SYSFS{idProduct}=="0015", RUN+="/sbin/fxload -v -t fx2 -I /opt/Xilinx/12.1/ISE_DS/ISE/bin/lin/xusb_xse.hex -D $tempnode"

Took me all the afternoon to figure it out... that and the right combination of settings. So far what I've done is:

* install Xilinx

* install libusb-dev and fxload

* put the .rules file on /etc/udev/rules.d/ (with the needed modifications: changing BUS to SUBSYSTEMS, $TEMPNODE to $tempnode, and /usr/share/ to <Xilinx folder>/ISE/bin/lin/ so you don't need to copy the hex files to /usr/share/, which is a horrible place for them), and restart the udev service (or the computer)

* link sh to bash, just in case (seems that some Xilinx scripts use bash-specific syntax that won't work on other shells such as dash)

* link gmake to make, since Xilinx sometimes uses a non-existing command called gmake instead of the make one

 

* create a launcher that sources the settings32.sh file (I posted it somewhere on the forum), and sets LANG="" (if your locale uses "," as a decimal separator instead of "." Xilinx will fail, so better to unset the locale)

And I think that's all I had to do so far. Maybe I make a Xilinx post-installation program that sets all this so you don't have to do it manually, but since each Xilinx version changes something, it would probably stop working next version.

BTW, gtkterm is a nice replacement for Windows HyperTerm, although normally you can just read /dev/ttyS0 with the `cat` command.

0 Kudos
dag1
Explorer
Explorer
38,490 Views
Registered: ‎12-08-2007

Thanks for this info

 

After following it, I was successful connecting impact on usb.

 

Ubuntu 10.04

Design Suite 13.1

 

Dag

0 Kudos