cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
7,430 Views
Registered: ‎09-03-2013

vivado 2013.4 initial multiboot image problem

Hi

my design is as follow

FPGA:K7 160t

tool: vivado 2013.4

FPGA is configured with  spi flash in x4 mode,the flash is 128Mbit and can hold two fpga image, golden image at 0x000000 and multiboot iamge at 0x700000.I want to make FPGA download multiboot image when power on.

 

as UG470 describe,design considerations for golden image and multiboot iamge are as follows:

无标题.png

 

so ,I set the conrresponding parameters in bitgen(open the implemented design,tools>set device property) as above,

but is doesn't works as expected.

 

now ,I want to know how to set the parameters in bitgen.

 

 

 

0 Kudos
2 Replies
Highlighted
Moderator
Moderator
7,423 Views
Registered: ‎01-15-2008

Re: vivado 2013.4 initial multiboot image problem

check the following link for the bitstream settings

http://www.xilinx.com/support/documentation/sw_manuals/xilinx2013_4/ug908-vivado-programming-debugging.pdf

 

  • set_property BITSTREAM.CONFIG.CONFIGFALLBACK Enable [current_design]
  • set_property BITSTREAM.CONFIG.SPI_BUSWIDTH 4 [current_design]
  • set_property BITSTREAM.CONFIG.NEXT_CONFIG_ADDR xxx  [current_design]

Also you can refer to kc705 multiboot reference design for bitstream settings. 

https://secure.xilinx.com/webreg/clickthrough.do?cid=354619&license=RefDesLicense&filename=rdf0191-kc705-multiboot-c-2013-4.zip&languageID=1

 

 

0 Kudos
Highlighted
Contributor
Contributor
7,374 Views
Registered: ‎09-03-2013

Re: vivado 2013.4 initial multiboot image problem

I set the parameters in bitgen,and the corresponding settings will be wrote to my xdc file. the golden image xdc includes some constraints about configration as follow set_property BITSTREAM.CONFIG.CONFIGRATE 16 [current_design] set_property BITSTREAM.CONFIG.SPI_BUSWIDTH 4 [current_design] set_property BITSTREAM.CONFIG.CONFIGFALLBACK ENABLE [current_design] set_property BITSTREAM.CONFIG.NEXT_CONFIG_ADDR 32'h00700000 [current_design] set_property BITSTREAM.CONFIG.TIMER_CFG 32'h4FFFFFFF [current_design] set_property CONFIG_MODE SPIx4 [current_design] but those constraints doesn't work
0 Kudos