UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
2,519 Views
Registered: ‎04-29-2012

Error in showing image on monitor2

Hello,

in continous of my last message, I'm trying to resolve shifting image problem.

I think READ LATENCY can make this problem, because the start point of image is shifted to right. How can I find how many pixels was lost?. It seems the end part of  each line of image is out of monitor.

Could you please guide me? How can I fix read latency problem? Does it make this problem?

About horizontal timing I've checked all frequency of design, they're correct. 

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
2,514 Views
Registered: ‎07-11-2011

Re: Error in showing image on monitor2

Hi,

 

Have you fully analyzed and cross checked on Bob inputs in your earlier post, Strongly  belive one among the below points will cause the pixel shift.

 

miscoded decodes of horizontal (pixel) counters

incorrect timing for transmitting the SAV (start of active video) flags

incorrect starting address for reading the DRAM video buffer (for each video line)

incorrect address for writing to the video buffer (for each video line)

 

One way is you can transmit  a fixed color data in place of video to check the number of pixels missing in the left edge, this will reval if your counters are mistaken are the video/bmp  data has shift.

 

Regards,

Vanitha

---------------------------------------------------------------------------------------------
Please do google search before posting, you may find relavant information.
Mark the post - "Accept as solution" and give kudos if information provided is helpful and reply oriented
0 Kudos