UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
299 Views
Registered: ‎08-22-2019

Having a "not connected to any source pin or I/O marker" error

I keep getting this error WARNING:DesignEntry:216 - mux8_sch.sch Net 'MUX_OUT(0)' is connected to load pins and/or I/O markers, but not connected to any source pin or I/O marker.

This is my full design that is supposed to be a 7:0 multiplexor.

 

I attached photos of the warnings and errors.Its for a class that just started.

 

I have attached a word document of the instructions.

 

I done everything up until the last part. :/ Please help. 

1.png2.pngerror1.pngwarninr1.png

0 Kudos
2 Replies
Highlighted
Teacher drjohnsmith
Teacher
275 Views
Registered: ‎07-09-2009

Re: Having a "not connected to any source pin or I/O marker" error

I would suggest deleting the offending nets and re making the connections,
I don't know if this is the cause, this sort of problem is common in schematic designs if you have "snap to grid" turned off,

<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
Teacher drjohnsmith
Teacher
275 Views
Registered: ‎07-09-2009

Re: Having a "not connected to any source pin or I/O marker" error

BTW: very few people design gate level logic using schematics, we use RTL languages such as VHDL,
<== If this was helpful, please feel free to give Kudos, and close if it answers your question ==>
0 Kudos