UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
2,665 Views
Registered: ‎06-25-2014

ISE 14.7 Install Issue

Jump to solution

Hi,

 

I have happily installed ISE 14.7 many times over the last few years on loads of PCs, but am having a "this is driving me crazy" moment on a new machine that I've never seen before. I am getting the following errors when running synthesis:

 

ERROR:Xst:2883 - Option "-verilog2001" is not available for the selected device family.
ERROR:Xst:2883 - Option "-mux_extract" is not available for the selected device family

 

The problem is exactly as described in AR# 46977

 

https://www.xilinx.com/support/answers/46977.html

 

I have tried reinstalling ISE, and even re-downloaded the 14.7 tar file from Xilinx, but the same issue persists.

 

 

I even tried adding "-Verilog2001 Off" into the synthesis "Other Command line options", but unfortunately it inserts this into the .xst file before the line that turns it back on again..

 

The machine is the same as many others in my office running Win 7 with a 4000 series i5 processor. (I.e. nothing special)

 

Licences are being picked up fine in the Xilinx license manger.

 

 

Any suggestions on this would be MUCH appreciated!

 

Thanks in advance!

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Explorer
Explorer
4,842 Views
Registered: ‎06-25-2014

Re: ISE 14.7 Install Issue

Jump to solution
Fixed!

I was wrong in that I had not actually tried the new download I made of ISE 14.7. (My mistake, somehow the old one was accidentally used again)

No idea why the .tar file I have been quite happily using for the last couple years has suddenly shown this issue. I can’t believe it has somehow become corrupted and yet installs/runs correctly.

So, to anyone else with this issue...

Re-download ISE14.7 and it then works!
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
2,641 Views
Registered: ‎04-16-2012

Re: ISE 14.7 Install Issue

Jump to solution

Hi @andrewlan

 

Compare the md5sum value of downloaded 14.7.tar file with website value.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Explorer
Explorer
4,843 Views
Registered: ‎06-25-2014

Re: ISE 14.7 Install Issue

Jump to solution
Fixed!

I was wrong in that I had not actually tried the new download I made of ISE 14.7. (My mistake, somehow the old one was accidentally used again)

No idea why the .tar file I have been quite happily using for the last couple years has suddenly shown this issue. I can’t believe it has somehow become corrupted and yet installs/runs correctly.

So, to anyone else with this issue...

Re-download ISE14.7 and it then works!
0 Kudos