cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
glissssbqwe
Newbie
Newbie
5,423 Views
Registered: ‎10-23-2013

ISE launches external editor failed

I'm trying to use an external editor for ISE, but I got the message

ERROR: launching custom editor subl failed: forked process couldn't set up input/output: bad file number

And I found the parameter $2 which was supposed to be the line number was actually a constant "1".

Anybody knows the solution?

P.S: I'm using ISE 14.4 under ubuntu 64.

0 Kudos
5 Replies
athandr
Xilinx Employee
Xilinx Employee
5,390 Views
Registered: ‎07-31-2012

Hello,

 

P.S: I'm using ISE 14.4 under ubuntu 64.

 

That is the problem here. Ubuntu is an unsupported OS for Xilinx ISE tools. So there are cases where you can see such problems. Better to move to a supported OS RHEL, Windows etc which should help you on this. This sure is an environment problem. Check the release note for the respective ISE for the supported Operating systems.

 

Thanks,

Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.
0 Kudos
athandr
Xilinx Employee
Xilinx Employee
5,375 Views
Registered: ‎07-31-2012

Hi,

 

Is your query resolved. Were you able to get rid of this error in a supported operating system.

 

 

Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.
0 Kudos
vuppala
Xilinx Employee
Xilinx Employee
5,351 Views
Registered: ‎04-16-2012

Hi,

Did you edit the settings under the menu Edit --> Preferences --> ISE General --> Editors.
See the following answer record: http://www.xilinx.com/support/answers/13713.htm

Thanks
--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
mwxilchip
Visitor
Visitor
4,716 Views
Registered: ‎05-15-2013

try the following workaround append "> /dev/null < /dev/null" to the editor cmd (linux only) for emacs : emacs +$2 $1 > /dev/null < /dev/null works fine for me found this workaround here http://computer-programming-forum.com/57-tcl/76c2ba0faab8eca8.htm
0 Kudos
mac1304
Visitor
Visitor
2,293 Views
Registered: ‎02-08-2011

Thanks, 


@mwxilchip wrote:
try the following workaround append "> /dev/null < /dev/null" to the editor cmd (linux only) for emacs : emacs +$2 $1 > /dev/null < /dev/null works fine for me found this workaround here http://computer-programming-forum.com/57-tcl/76c2ba0faab8eca8.htm

This is the answer. This forum will benefit more with this type of answers which improve community empathy than with "your OS is not supported" kind of formality. Ubuntu is not a minor distribution a we're not lawyers. Keep that in mind

 

0 Kudos