cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor
Visitor
2,316 Views
Registered: ‎07-19-2017

PS Pushbutton Latching to high in zc702

Jump to solution

HI, i am quite new to using the zynq zc7020 soc and i'm facing an issue where the ps push button is latching to high(1), i don't seem to find any errors or warnings in the code that i copied from a link. My goal was to light up any PL led by using SW13(MIO14). i wrote the code on sdk and ran the debug, set the expression sw to be watched.

I have attached the screen shots of whats happening step by step and also have attached the code.

 

I did not include the led in the code because i wanted to test the switch first.

Please help.Before.jpg  I haven't pressed the switch. after read.jpgend_of_loop.jpgjumps_into_disassembly.jpg

i tested the push button using a CRO and it was working fine.

your help will be much appreciated! 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Visitor
Visitor
3,975 Views
Registered: ‎07-19-2017

Re: PS Pushbutton Latching to high in zc702

Jump to solution

Hey, i got the solution, kind of stupid actually, i didn't disable the pull up resistor while creating the .hdf file. All i had to do was go back to the vivado design tool, disable the MIO14/12 pin resistor pull up in the block configuring settings and generate the .hdf again.

thanks. 

View solution in original post

MIOPUR.jpg
0 Kudos
1 Reply
Highlighted
Visitor
Visitor
3,976 Views
Registered: ‎07-19-2017

Re: PS Pushbutton Latching to high in zc702

Jump to solution

Hey, i got the solution, kind of stupid actually, i didn't disable the pull up resistor while creating the .hdf file. All i had to do was go back to the vivado design tool, disable the MIO14/12 pin resistor pull up in the block configuring settings and generate the .hdf again.

thanks. 

View solution in original post

MIOPUR.jpg
0 Kudos