cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Newbie
Newbie
10,392 Views
Registered: ‎08-27-2014

Platform Cable USB II Stopped Working

Jump to solution

Hi all,

 

I have successfully been using the Platform Cable USB II to program a Spartan 6 for around 6 month.  Today I tried to load a new program and I could not connect to the cable.  See below for the message iMPACT gives me.  When I came in to use ISE and iMPACT today ISE said my license was no longer valid; I pointed ISE to the license file I had always been using (located in C:\Xilinx) and ISE stopped complaining.  AS far as know nothing else in my system has changed since the last time I programmed the Spartan 6.  The Platform cable light is green and Windows recognizes the cable just fine.  I am using Windows 7 and ISE 13.4 (nt64).  I have checked other posts and it seems this is not a new issue, but I was unable to fix the problem by following any of those suggestions.  Please help!  Thanks,

Aaron

 

 

 

AutoDetecting cable. Please wait.
PROGRESS_START - Starting Operation.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
 Driver file xusb_emb.sys found.
 Driver version: src=1029, dest=1029.
 Driver windrvr6.sys version = 11.6.0.0. WinDriver v11.6.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jun  9 2014 x86_64 64bit SYS 10:03:05, version = 1160.
Invalid device driver license.
Cable connection failed.
Connecting to cable (Parallel Port - LPT1).
Checking cable driver.
 Driver windrvr6.sys version = 11.6.0.0. WinDriver v11.6.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jun  9 2014 x86_64 64bit SYS 10:03:05, version = 1160.
Cable connection failed.
Connecting to cable (Parallel Port - LPT2).
Checking cable driver.
 Driver windrvr6.sys version = 11.6.0.0. WinDriver v11.6.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jun  9 2014 x86_64 64bit SYS 10:03:05, version = 1160.
Cable connection failed.
Connecting to cable (Parallel Port - LPT3).
Checking cable driver.
 Driver windrvr6.sys version = 11.6.0.0. WinDriver v11.6.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jun  9 2014 x86_64 64bit SYS 10:03:05, version = 1160.
Cable connection failed.
Connecting to cable (Parallel Port - LPT4).
Checking cable driver.
 Driver windrvr6.sys version = 11.6.0.0. WinDriver v11.6.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Jun  9 2014 x86_64 64bit SYS 10:03:05, version = 1160.
Cable connection failed.
PROGRESS_END - End Operation.
Elapsed time =     32 sec.
Cable autodetection failed.
WARNING:iMPACT:923 - Can not find cable, check cable setup !

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
14,939 Views
Registered: ‎07-31-2012

Hi,

 

Try uninstalling and reinstalling the Jungo Drivers as below.

 

 

1) In the Xilinx command prompt (not the regular windows command prompt) browse to your C:/Xilinx/<ise_version>/ISE_DS/ISE/bin/nt directory on 32-bit installs. i.e. type cd C:/Xilinx/<ise_version>/ISE_DS/ISE/bin/nt

 

2) To uninstall the jungo drivers type the command:  wdreg -compat -inf windrvr6.inf uninstall

 

3)    To reinstall the jungo drivers type the command:  wdreg -compat -inf windrvr6.inf install

 

After these steps the cable connection should work fine.

 

Check the device manager to see if you can see Jungo Drivers as below

 

jungo.png

Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.

View solution in original post

0 Kudos
14 Replies
Highlighted
Xilinx Employee
Xilinx Employee
10,380 Views
Registered: ‎07-21-2014

hi,

 

If you connect the Platform Cable USB-II to the PC and the STATUS LED on the cable a very dim yellow, the cause could be that the correct cable driver is not installed.

1. Download the Xilinx USB Cable Installation Guide (UG344) from:

http://www.xilinx.com/support/documentation/configuration_hardware.htm

2. Follow the procedure for your OS in "Step 5: Install the Xilinx USB Cable".

 

thanks

Shreyas

 

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

----------------------------------------------------------------------------------------------
Try to search answer for your issue in forums or xilinx user guides before you post a new thread.

Kindly note- Please mark the Answer as "Accept as solution" if information provided solves your query.
Give Kudos (star provided in right) to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
10,379 Views
Registered: ‎07-21-2014

Hi,

 

following can also be the cause for this issue

 

Drivers targeting the incorrect PC architecture are installed. A 32-bit ISE install can be used on a 64-bit machine, but the drivers are not compatible. To use a Xilinx Programming Cable on a 64-bit machine, you need a 64-bit iMPACT install with the cable drivers installed.

 

thanks

Shreyas

 

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------

----------------------------------------------------------------------------------------------
Try to search answer for your issue in forums or xilinx user guides before you post a new thread.

Kindly note- Please mark the Answer as "Accept as solution" if information provided solves your query.
Give Kudos (star provided in right) to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Moderator
Moderator
10,373 Views
Registered: ‎07-21-2014

Hi,

 

Check below AR

http://www.xilinx.com/support/answers/30307.html

 

Thanks,
Anusheel
-----------------------------------------------------------------------------------------------
Search for documents related to your device and tool before posting query.
Search related forums and make sure your query is not repeated.

 

Please mark the post as an answer "Accept as solution" in case it helped to resolve your query.
Give kudos for accepted solution.
-----------------------------------------------------------------------------------------------

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
14,940 Views
Registered: ‎07-31-2012

Hi,

 

Try uninstalling and reinstalling the Jungo Drivers as below.

 

 

1) In the Xilinx command prompt (not the regular windows command prompt) browse to your C:/Xilinx/<ise_version>/ISE_DS/ISE/bin/nt directory on 32-bit installs. i.e. type cd C:/Xilinx/<ise_version>/ISE_DS/ISE/bin/nt

 

2) To uninstall the jungo drivers type the command:  wdreg -compat -inf windrvr6.inf uninstall

 

3)    To reinstall the jungo drivers type the command:  wdreg -compat -inf windrvr6.inf install

 

After these steps the cable connection should work fine.

 

Check the device manager to see if you can see Jungo Drivers as below

 

jungo.png

Thanks,
Anirudh

PS: Please MARK this as an answer in case it helped resolve your query.Give kudos in case the post guided you to a solution.

View solution in original post

0 Kudos
Highlighted
Newbie
Newbie
10,313 Views
Registered: ‎08-27-2014

Thanks to athandr for essentially suplying the solution.  I did have to alter the commands slightly: I went into the .../bin/nt64 directory instead of the .../bin/nt directory.  I also had to add .exe to wdreg in the install/uninstall commands.  The exact sequence of commands I did are below:

 

1) In the Xilinx command prompt (not the regular windows command prompt) browse to your C:/Xilinx/<ise_version>/ISE_DS/ISE/bin/nt directory on 64-bit installs. i.e. type:

cd C:/Xilinx/<ise_version>/ISE_DS/ISE/bin/nt64

 

2) To uninstall the jungo drivers type the command:  wdreg.exe -compat -inf windrvr6.inf uninstall

 

3) To reinstall the jungo drivers type the command:  wdreg.exe -compat -inf windrvr6.inf install

0 Kudos
Highlighted
Observer
Observer
8,617 Views
Registered: ‎12-14-2011

Hey. Thanks for supplying a solution. Unfotunately, when I try this I get the following:

 

WDREG utility v10.21. Build Aug 31 2010 14:21:54

Error: Cannot open service control manager.

Make sure you are running with Administrator privileges

Error: Initializing driver failed

 

 

I have admin priviledges on my PC. I can't figure out how to get round this. Any ideas??? For what it's worth, I also tried reinstalling the drivers as per UG344 (?) and had no luck there. 

 

Clearly many others have had the same problem. Working fine for months, then one day it just stops! Anyone from Xilinx able to shed some light?

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
8,610 Views
Registered: ‎04-16-2012

Hello @alanbrennan

 

1. Invoke Command Prompt as administrator (right-click --> Run as administrator)

2. First run the uninstall command: wdreg.exe -compat -inf windrvr6.inf uninstall

3. Then run the install command: wdreg.exe -compat -inf windrvr6.inf install

 

Which OS are you using?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
0 Kudos
Highlighted
Observer
Observer
8,604 Views
Registered: ‎12-14-2011

Thanks for the help. Very useful! I've done the uninstall -> install again. Unfortunately, it doesn't solve my problem. Cable is plugged in. Green light is on. Jungo windows driver appears in devices. But still error code 923. Grrr. Annoying!

 

INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: no JTAG device was found.
AutoDetecting cable. Please wait.
PROGRESS_START - Starting Operation.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
Driver file xusb_xp2.sys found.
Driver version: src=2301, dest=2301.
Driver windrvr6.sys version = 11.7.0.0. WinDriver v11.7.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Oct 26 2014 x86_64 64bit SYS 09:16:51, version = 1170.
Invalid device driver license.
Cable connection failed.
Connecting to cable (Parallel Port - LPT1).
Checking cable driver.
Driver windrvr6.sys version = 11.7.0.0. WinDriver v11.7.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Oct 26 2014 x86_64 64bit SYS 09:16:51, version = 1170.
Cable connection failed.
Connecting to cable (Parallel Port - LPT2).
Checking cable driver.
Driver windrvr6.sys version = 11.7.0.0. WinDriver v11.7.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Oct 26 2014 x86_64 64bit SYS 09:16:51, version = 1170.
Cable connection failed.
Connecting to cable (Parallel Port - LPT3).
Checking cable driver.
Driver windrvr6.sys version = 11.7.0.0. WinDriver v11.7.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Oct 26 2014 x86_64 64bit SYS 09:16:51, version = 1170.
Cable connection failed.
Connecting to cable (Parallel Port - LPT4).
Checking cable driver.
Driver windrvr6.sys version = 11.7.0.0. WinDriver v11.7.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Oct 26 2014 x86_64 64bit SYS 09:16:51, version = 1170.
Cable connection failed.
PROGRESS_END - End Operation.
Elapsed time = 2 sec.
Cable autodetection failed.
WARNING:iMPACT:923 - Can not find cable, check cable setup !

 

 

 

 

0 Kudos
Highlighted
Visitor
Visitor
7,731 Views
Registered: ‎07-15-2015

When I run the uninstall command: wdreg.exe -compat -inf windrvr6.inf uninstall

I get a message saying there is currently 1 open application using WinDriver. Please close all applications and press Retry. To reload WinDriver, press cancel and reboot. 

I've unplugged my cable and rebooted my PC but still get the same message when I run the uninstall. There is nothing in task manager for WinDriver or wdreg.

Any ideas?

0 Kudos
Highlighted
Visitor
Visitor
4,271 Views
Registered: ‎07-15-2015

I disabled windrv from device manager then rebooted. I was then able to run uninstall and then install. No effect. Still get error saying:  Driver windrvr6.sys version = 11.7.0.0. WinDriver v11.7.0 Jungo Connectivity (c) 1997 - 2014 Build Date: Oct 26 2014 x86_64 64bit SYS 09:16:51, version = 1170.
Invalid device driver license.

0 Kudos
Highlighted
4,081 Views
Registered: ‎09-07-2015

Hi all,

 

Please try to delete windrvr6.sys under C:\Windows\system32\drivers after uninstall windrvr6.sys.

 

Normally, windrvr6.sys version is 10.21 that installed with LabTools.

 

 

Highlighted
3,967 Views
Registered: ‎01-25-2016

thanks for the posts. I had to delete my windrv6.sys file becasue it was newer than the one that was installed by the Jungo driver to resolve this issue.

0 Kudos
Highlighted
Participant
Participant
3,958 Views
Registered: ‎10-17-2008

Had same problem with the reported "invalid device driver license", and the same fix worked for me.  First, I uninstalled windrvr6.sys, then removed it from c:\windows\system32\drivers, then reinstalled it. 

 

My platform is running Windows 10 64-bit, ISE WebPack 14.7 64 bit with a Platform Cable USB I.

 

The size/date info of the two windrvr6.sys files:

01/28/2014  08:59 AM           268,800 windrvr6.sys  -- this newer one did not work
10/13/2013  10:49 AM           254,976 windrvr6.sys  -- this older one worked

 

Highlighted
Visitor
Visitor
3,616 Views
Registered: ‎12-15-2011

Hi All,

 

the trick with uninstalling/deleting/reinstalling windrvr6 worked also in my case (no computer restart required). I had problem with both Digilent and Xilinx programmers under both ISE Impact and Vivado hw_server. What I would like to add to the discussion is that in my case the "wrong" windrvr6.sys file was provided by recent Atmel Studio installation.

 

Summing up, if your Digilent or Xilinx Platform Cable stopped working after installing Atmel Studio - the aforementioned procedure should help.

 

Regards,

Olek

0 Kudos