cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
2,099 Views
Registered: ‎08-26-2008

TFT issue with EDK 14.2 & 14.3 --

Hi,

 
I used EDK 14.1 and added the TFT ip in microblaze project and it worked well but in EDK 14.2 and 14.3 did the same steps and added same tft ip, exported to SDK and then tried to make the new BSP but gives an error as following senescence shows:
==========================
"Compiling standalone";
"Compiling common"
mb-ar: creating ./libsyscall.a
mb-ar: creating ./libxilkernel.a
"Compiling xilkernel"
"Compiling bram"
"Compiling gpio"
"Compiling uartlite"
"Compiling intc"
"Compiling ps2"
"Compiling tft"
xtft.c: In function 'XTft_GetPixel':
xtft.c:1082:0: error: unterminated argument list invoking macro "Xil_In32"
xtft.c:367:14: error: 'Xil_In32' undeclared (first use in this function)
xtft.c:367:14: note: each undeclared identifier is reported only once for each function it appears in
xtft.c:367:2: error: expected ';' at end of input
xtft.c:367:2: error: expected declaration or statement at end of input
make[1]: *** [libs] Error 1
======================================
 
If i remove the tft again from microblaze project then works fine. Could you please tell me about the problem asap.
 
Thank you in advance.
0 Kudos
0 Replies