UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor pfxr
Visitor
3,129 Views
Registered: ‎06-11-2014

Vivado issue repackaging IP

Hello,

I'm a new to FPGA's and Vivado, and i recently bought a microzed board.
I was trying to make a connection from PS to PL and make a simple calculator to start. So I've done this:

 

http://forums.xilinx.com/t5/Xcell-Daily-Blog/The-Zynq-PS-PL-Part-Two-Adam-Taylor-s-MicroZed-Chronicles-Part/ba-p/422249

And then I sythesized, implemented and exported bitstream to SDK. In SDK i ran the self-test of the block and it says it passed. Just like in here:

http://forums.xilinx.com/t5/Xcell-Daily-Blog/The-Zynq-PS-PL-Part-Three-Adam-Taylor-s-MicroZed-Chronicles-Part/ba-p/425154


Til here everything was fine, but then i wanted to change the block code so i could implement my calculator, and here is where I'm stuck. I right click the block on Vivado and click "Edit IP in Packager", here I change the code and it doesn't matter how much I change it because the changes won't be recognized.

I mean, when I repackage it after the changes are made, I do all the steps above (Synthesis, Implementation and bitstream), but when I write the code in C on SDK the changes I've made in the code of my block aren't there, the Self-test always passes and i can't implement the calculator.
I've tryed to change all the code that was in the block so I was sure that the Self-Test was going to fail, but it doesn't fail...



Am I missing some step while repackaging the block or something?

I would really appreciate some help here.

Sorry for my bad english,

Pedro Rodrigues

0 Kudos
2 Replies
Moderator
Moderator
3,121 Views
Registered: ‎01-16-2013

Re: Vivado issue repackaging IP

Hello,

I have come across one issue in that after edit and re-package IP tool create new file sets and without removing the older one and tool uses older one for the simulation. I guess in your case same this is happening.

Workaround: Please try to edit and repackage IP by changing version number. so tool will pick bigger version (i.e. latest one)

Hope it will work.

Thanks,
Yash
Visitor pfxr
Visitor
3,090 Views
Registered: ‎06-11-2014

Re: Vivado issue repackaging IP

Thanks for your reply :)
Sadly, I'm still stuck with the same problem. The changes i do in the block aren't doing any efect.

P.S. I've marked this as solved but it was my mistake. Sorry

0 Kudos