UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Newbie yxl
Newbie
5,798 Views
Registered: ‎07-24-2016

how to set enable_mmc in SDK

Jump to solution

hi

i want to boot zedboard from QSPI+EMMC,i placed the FSBL on the QSPI flash and all the other partitions are on eMMC flash.

i want to know how to create a BSP with the library and set enable_mmc in the SDK options. how to find this enable_mmc setting?

thanks

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
10,752 Views
Registered: ‎08-01-2008

Re: how to set enable_mmc in SDK

Jump to solution

1) edit the system.mss and select modify the BSP settings
2) in the Board Support package Settings window, set enable_mmc to true
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
7 Replies
Xilinx Employee
Xilinx Employee
5,791 Views
Registered: ‎08-01-2008

Re: how to set enable_mmc in SDK

Jump to solution
Create a BSP with the library and set enable_mmc in the SDK options. For more details, see the library documentation

http://www.xilinx.com/support/documentation/user_guides/ug821-zynq-7000-swdev.pdf
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Newbie yxl
Newbie
5,790 Views
Registered: ‎07-24-2016

Re: how to set enable_mmc in SDK

Jump to solution

i can’t find detail information in ug821.

thanks

0 Kudos
Newbie yxl
Newbie
5,789 Views
Registered: ‎07-24-2016

Re: how to set enable_mmc in SDK

Jump to solution

could you please show me where can find it ?

0 Kudos
Xilinx Employee
Xilinx Employee
10,753 Views
Registered: ‎08-01-2008

Re: how to set enable_mmc in SDK

Jump to solution

1) edit the system.mss and select modify the BSP settings
2) in the Board Support package Settings window, set enable_mmc to true
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
Newbie yxl
Newbie
5,775 Views
Registered: ‎07-24-2016

Re: how to set enable_mmc in SDK

Jump to solution

I have tried,but i didnt find enable_mmc flag .please refer to the attached BSP.pdf

0 Kudos
Observer lophope
Observer
5,760 Views
Registered: ‎05-03-2011

Re: how to set enable_mmc in SDK

Jump to solution

 

One another question:What's the fs_interface value when MMC is enable?

MMC.png
0 Kudos
Visitor dev_123
Visitor
83 Views
Registered: ‎11-02-2018

Re: how to set enable_mmc in SDK

Jump to solution

For me this option is not coming

BSPSettings.png

I am using below xilinx SDK version

XilinxSDKVersion.png

By the, I want to use MicroSD instead of eMMC , but for me it's selecting eMMC :(

I am using Avnet Ultrazed-EG with IO Carrier card

Thanks in advance !!

0 Kudos