cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Participant
Participant
4,447 Views
Registered: ‎05-06-2009

tft controller

Hello every body ,

I would like to display a sequence video using virtex 5 (xupv5) FPGA.  I have add tft controller in my projet and I have written a c code to pilot the tft .

Please,  I would know if  you should  have a 640x 480  tft screen or I can use lcd screen?

Thank you  in advance

Tags (1)
0 Kudos
3 Replies
Highlighted
Instructor
Instructor
4,442 Views
Registered: ‎07-21-2009

If your LCD monitor supports 640x480 mode, this should work fine.  All HDMI-input monitors support 640x480 video input, it's a requirement of the HDMI specification.

 

By the way, 'tft' is a form of LCD display.  It stands for 'thin film transistor'.

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
4,394 Views
Registered: ‎02-05-2008

The last post in this topic was moved by the moderator which caused an audit trail on the last person to reply. The last person to address the users post was eteam00. Our apologies for any inconvenience.

 

Thank you,

alexisc

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
4,100 Views
Registered: ‎08-26-2008

Hi,

 
I used EDK 14.1 and added the TFT ip in microblaze project and it worked well but in EDK 14.2 and 14.3 did the same steps and added same tft ip, exported to SDK and then tried to make the new BSP but gives an error as following senescence shows:
==========================
"Compiling standalone";
"Compiling common"
mb-ar: creating ./libsyscall.a
mb-ar: creating ./libxilkernel.a
"Compiling xilkernel"
"Compiling bram"
"Compiling gpio"
"Compiling uartlite"
"Compiling intc"
"Compiling ps2"
"Compiling tft"
xtft.c: In function 'XTft_GetPixel':
xtft.c:1082:0: error: unterminated argument list invoking macro "Xil_In32"
xtft.c:367:14: error: 'Xil_In32' undeclared (first use in this function)
xtft.c:367:14: note: each undeclared identifier is reported only once for each function it appears in
xtft.c:367:2: error: expected ';' at end of input
xtft.c:367:2: error: expected declaration or statement at end of input
make[1]: *** [libs] Error 1
======================================
 
If i remove the tft again from microblaze project then works fine. Could you please tell me about the problem asap.
 
Thank you in advance.
0 Kudos