cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
haggaie
Adventurer
Adventurer
1,374 Views
Registered: ‎06-28-2016

Disabling 'relax_ii_for_timing' in Vivado 2019.2

Jump to solution

Hi,

When running Vivado HLS I got this in the log:

INFO: [SCHED 204-61] Option 'relax_ii_for_timing' is enabled, will increase II to preserve clock frequency constraints.

I want to disable relax_ii_for_timing then. However, it looks like the default is to enable it, and the flag in config_schedule can also only enable it. Is there no way to disable this setting or am I missing something?

Here's the output of config_schedule -help:

> config_schedule -help
FORMAT
config_schedule [OPTIONS]
-effort (high | *medium* | low)
-enable_dsp_full_reg
-relax_ii_for_timing (default: 1)
-verbose

Thanks,

Haggai

0 Kudos
1 Solution

Accepted Solutions
nithink
Xilinx Employee
Xilinx Employee
1,291 Views
Registered: ‎09-04-2017

@haggaie   sorry there was a miss

config_schedule -relax_ii_for_timing=0

Have equal to as well

Thanks,

Nithin

View solution in original post

0 Kudos
6 Replies
nithink
Xilinx Employee
Xilinx Employee
1,318 Views
Registered: ‎09-04-2017

@haggaie  you can use

config_schedule -relax_ii_for_timing 0

Thanks,

Nithin

0 Kudos
haggaie
Adventurer
Adventurer
1,295 Views
Registered: ‎06-28-2016

Thanks, but this results in an error:

ERROR: [HLS 200-101] 'config_schedule': Unknown option '0'.
FORMAT
  config_schedule [OPTIONS]
    -effort (high | *medium* | low)
    -enable_dsp_full_reg
    -relax_ii_for_timing (default: 1)
    -verbose

command 'config_schedule' returned error code
    while executing
"config_schedule -relax_ii_for_timing 0"
0 Kudos
nithink
Xilinx Employee
Xilinx Employee
1,292 Views
Registered: ‎09-04-2017

@haggaie   sorry there was a miss

config_schedule -relax_ii_for_timing=0

Have equal to as well

Thanks,

Nithin

View solution in original post

0 Kudos
haggaie
Adventurer
Adventurer
1,280 Views
Registered: ‎06-28-2016
Thanks, this worked for me.
0 Kudos
zhanghaha
Visitor
Visitor
745 Views
Registered: ‎10-17-2020

我想问一下,config_schedule -relax_ii_for_timing=0这个命令添加在什么地方

0 Kudos
haggaie
Adventurer
Adventurer
736 Views
Registered: ‎06-28-2016

I've used this option in a tcl script where I launch the HLS synthesis process.

0 Kudos