cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
6,026 Views
Registered: ‎06-17-2012

Exporting PCore for EDK error using vivado HLS 2013.3

Jump to solution

I have a simple matrix multiplication desin and I want to export it as a Pcore in EDK. However, it turned out the following error.

 

@E [IMPL-39] Cannot find ISE in the PATH variable or it's an unsupported version. Please update the PATH variable to include a supported version (13.1 and above)

while executing
"export_design -evaluate verilog -format pcore -version "1.00.a" -use_netlist none"

 

I double check the PATH, I did put the ISE path in. In addition, when I export it to IP catalog, it works fine. 

Anyone could help me with this?

 

BTW, The ISE is 14.7 which is shipped together with the vivado ISE 2013,3.

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Scholar
Scholar
9,621 Views
Registered: ‎06-14-2012

This seems to be a known issue. Can you check if this is an issue?

 

The xtclsh of Vivado installation corrupts the xtclsh of ISE installation. Command "which xtclsh" can be used to find out which xtclsh is being used.

Setting xtclsh of ISE installation in environment instead of xtclsh of Vivado installation to resolve the issue.

View solution in original post

0 Kudos
2 Replies
Highlighted
Scholar
Scholar
9,622 Views
Registered: ‎06-14-2012

This seems to be a known issue. Can you check if this is an issue?

 

The xtclsh of Vivado installation corrupts the xtclsh of ISE installation. Command "which xtclsh" can be used to find out which xtclsh is being used.

Setting xtclsh of ISE installation in environment instead of xtclsh of Vivado installation to resolve the issue.

View solution in original post

0 Kudos
Highlighted
Explorer
Explorer
6,016 Views
Registered: ‎06-17-2012

I think it should be a known issue, and I found the solution in previous post.

http://forums.xilinx.com/t5/High-Level-Synthesis-HLS/Export-RTL-VHDL-ISE-error/td-p/286381

 

It is my own fault. when I added the newly installed ISE path to $PATH, I have typo there.

0 Kudos