UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
465 Views
Registered: ‎04-28-2015

Vivado HLS Co-Simulation Waveforms missing

Jump to solution

I downloaded the sample multi_chan_conv_fil from Github.

I brought it into Vivado HLs so that I could experiment and see if I could change the interface to streaming. Without making many changes I attempted to look at the interface signals in the waveform viewer. I am using Verilog and am at Vivado HLS 2016.3. The problem is, is that there are no waveforms showing even though the simulation is showing as having passed. See the attached picture. What am I doing wrong?

Thanks

Tags (1)
Fil.JPG
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
453 Views
Registered: ‎05-31-2017

Re: Vivado HLS Co-Simulation Waveforms missing

Jump to solution

Hi tphelan@miyachiamerica.com,

Please click on the + sign present at the name in the waveform window. Check the hierarchy and you can see the waveforms for the signals.

0 Kudos
2 Replies
Moderator
Moderator
454 Views
Registered: ‎05-31-2017

Re: Vivado HLS Co-Simulation Waveforms missing

Jump to solution

Hi tphelan@miyachiamerica.com,

Please click on the + sign present at the name in the waveform window. Check the hierarchy and you can see the waveforms for the signals.

0 Kudos
448 Views
Registered: ‎04-28-2015

Re: Vivado HLS Co-Simulation Waveforms missing

Jump to solution
Wow, that's all it was.
Thanks
0 Kudos