cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mspalpsahan
Adventurer
Adventurer
1,392 Views
Registered: ‎10-13-2018

it can not compile C synthesis on windows10

Jump to solution

hi

it is compile C synthesis and export RTL on windows 7. but it is not working on windows 10.

it working the project file on windows7 but, not working same the project file on windows 10

***** problem on windows 10 *****

WARNING: [HLS 200-40] In file included from source/plate_recognation.cpp:1:
In file included from source/plate_recognation.cpp:1:
In file included from source/plate_recognation.h:1:
In file included from C:/Xilinx/Vivado/2019.1/common/technology/autopilot\hls_video.h:57:
C:/Xilinx/Vivado/2019.1/common/technology/autopilot/hls/hls_video_core.h:571:7: error: calling a private constructor of class 'hls::stream<unsigned char>'
class Mat {
^
C:/Xilinx/Vivado/2019.1/common/technology/autopilot/hls_stream.h:91:43: note: declared private here
inline __attribute__((always_inline)) stream(const stream< __STREAM_T__ >& chn):V(chn.V) {
^
source/plate_recognation.cpp:12:19: note: implicit default copy constructor for 'hls::Mat<720, 1280, 4096>' first required here
_ssdm_SpecStream( img0, 1, 1, "");
^
source/plate_recognation.cpp:12:19: error: cannot pass object of non-POD type 'rgb_img_t' (aka 'Mat<720, 1280, (((0) & ((1 << 11) - 1)) + (((3) - 1) << 11))>') through variadic function; call will abort at runtime [-Wnon-pod-varargs]
_ssdm_SpecStream( img0, 1, 1, "");
^
source/plate_recognation.cpp:14:19: error: no matching constructor for initialization of 'rgb_img_t' (aka 'Mat<720, 1280, (((0) & ((1 << 11) - 1)) + (((3) - 1) << 11))>')
_ssdm_SpecStream( img1, 1, 1, "");
^~~~
C:/Xilinx/Vivado/2019.1/common/technology/autopilot/hls/hls_video_core.h:575:5: note: candidate constructor not viable: no known conversion from 'rgb_img_t' (aka 'Mat<720, 1280, (((0) & ((1 << 11) - 1)) + (((3) - 1) << 11))>') to 'Size' (aka 'Size_<int>') for 1st argument;
Mat(Size _sz);
^
C:/Xilinx/Vivado/2019.1/common/technology/autopilot/hls/hls_video_core.h:573:5: note: candidate constructor not viable: requires 0 arguments, but 1 was provided
Mat();
^
C:/Xilinx/Vivado/2019.1/common/technology/autopilot/hls/hls_video_core.h:574:5: note: candidate constructor not viable: requires 2 arguments, but 1 was provided
Mat(int _rows, int _cols);
^
3 errors generated.
Compilation of the preprocessed source 'plate_recognation' failed
while executing
"source D:/Plate_regonaiton/HLS/plate_recognation/solution2/csynth.tcl"
invoked from within
"hls::main D:/Plate_regonaiton/HLS/plate_recognation/solution2/csynth.tcl"
("uplevel" body line 1)
invoked from within
"uplevel 1 hls::main {*}$args"
(procedure "hls_proc" line 5)
invoked from within
"hls_proc $argv"
Finished C synthesis.

 

**** no problem on windows 7***

the export file attechment

what is the solve?

0 Kudos
1 Solution

Accepted Solutions
mspalpsahan
Adventurer
Adventurer
1,219 Views
Registered: ‎10-13-2018

hi

1. Do you see the same issue on other windows 10 machine --> This confirms if this is machine specific issue. yes i see the same issue other win10 machine. it is just working win7 two computer.

2. You can also try by commenting the pragmas few at a time and then run synthesis --> This confirms if this issue is related to pragmas. i tried for the pragrams

Thank you for interested

Alpaslan Sahan

 

View solution in original post

0 Kudos
7 Replies
hemangd
Moderator
Moderator
1,323 Views
Registered: ‎03-16-2017

Hi @mspalpsahan , 

Are you using supported Windows 10 version for Vivado 2019.1 as shown below?

• Microsoft Windows 10.0 1809 Update; 10.0 1903 Pre-release (64-bit), English/Japanese

Please test it on supported windows 10 version. 

 

ff the issue persists, then provide your archived test case to evaluate it at our end. Send you ezmove ftp on your email through which you can provide it. 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
shameera
Moderator
Moderator
1,311 Views
Registered: ‎05-31-2017

Hi @mspalpsahan ,

As this issue does not occur on Windows 7 machine, few suggestions to check is,

1. Do you see the same issue on other windows 10 machine --> This confirms if this is machine specific issue.

2. You can also try by commenting the pragmas few at a time and then run synthesis --> This confirms if this issue is related to pragmas.

 

0 Kudos
mspalpsahan
Adventurer
Adventurer
1,284 Views
Registered: ‎10-13-2018

hi

thank you very much for interest

the issue persists. My OS windows 10 1903

my email alpsahan@hotmail.com

 

have nice day

 

Alpaslan Sahan

0 Kudos
hemangd
Moderator
Moderator
1,276 Views
Registered: ‎03-16-2017

Hi @mspalpsahan , 

Sent you ezmove ftp test package. 

Regards,
hemangd

Don't forget to give kudos and mark it as accepted solution if your issue gets resolved.
0 Kudos
mspalpsahan
Adventurer
Adventurer
1,255 Views
Registered: ‎10-13-2018

hi

do you solve?

best regards

Alpaslan sahan

0 Kudos
mspalpsahan
Adventurer
Adventurer
1,220 Views
Registered: ‎10-13-2018

hi

1. Do you see the same issue on other windows 10 machine --> This confirms if this is machine specific issue. yes i see the same issue other win10 machine. it is just working win7 two computer.

2. You can also try by commenting the pragmas few at a time and then run synthesis --> This confirms if this issue is related to pragmas. i tried for the pragrams

Thank you for interested

Alpaslan Sahan

 

View solution in original post

0 Kudos
mspalpsahan
Adventurer
Adventurer
1,207 Views
Registered: ‎10-13-2018

hi everyone

i find issue. it is have problem The Turkish character. 

i did install OS windows English language on my computer. this solved.

OS must be in english

I write for everyone to know

Alpaslan Sahan